summaryrefslogtreecommitdiff
path: root/net-misc/udpcast/udpcast-20211207.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-31 10:50:20 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-31 10:50:20 +0100
commitc3b55a6be7da027d97d8aef00ef88c3011121a42 (patch)
tree3931524f7f6f9958aa6427f6a11a0df28ff99a30 /net-misc/udpcast/udpcast-20211207.ebuild
parentc8f83ad526fb6b554daf375e0ad65eb2d56e669b (diff)
gentoo auto-resync : 31:08:2022 - 10:50:20
Diffstat (limited to 'net-misc/udpcast/udpcast-20211207.ebuild')
-rw-r--r--net-misc/udpcast/udpcast-20211207.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-misc/udpcast/udpcast-20211207.ebuild b/net-misc/udpcast/udpcast-20211207.ebuild
new file mode 100644
index 000000000000..e2165f829f27
--- /dev/null
+++ b/net-misc/udpcast/udpcast-20211207.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic
+
+DESCRIPTION="Multicast file transfer tool"
+HOMEPAGE="https://www.udpcast.linux.lu/"
+SRC_URI="https://www.udpcast.linux.lu/download/${P}.tar.gz"
+
+LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="hardened"
+
+BDEPEND="dev-lang/perl"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-musl.patch
+)
+
+src_configure() {
+ use hardened || append-cppflags -DUSE_ASSEMBLER
+
+ default
+}
+
+src_install() {
+ default
+ dodoc *.txt
+}