summaryrefslogtreecommitdiff
path: root/net-misc/trurl/trurl-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-06 11:27:38 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-06 11:27:38 +0100
commitefca56beb6bbb9547d49163cac02eac0b5c1f657 (patch)
tree8bf6231248f07665ec95268dc33bf4acfde82f63 /net-misc/trurl/trurl-9999.ebuild
parent99d38fd80dbcd05d7ac05f9fbc86c396bacd5f7c (diff)
gentoo auto-resync : 06:04:2023 - 11:27:37
Diffstat (limited to 'net-misc/trurl/trurl-9999.ebuild')
-rw-r--r--net-misc/trurl/trurl-9999.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/net-misc/trurl/trurl-9999.ebuild b/net-misc/trurl/trurl-9999.ebuild
index d746c034e362..5c9ebf0edda3 100644
--- a/net-misc/trurl/trurl-9999.ebuild
+++ b/net-misc/trurl/trurl-9999.ebuild
@@ -6,7 +6,7 @@ EAPI=8
inherit toolchain-funcs
DESCRIPTION="Command line tool for URL parsing and manipulation"
-HOMEPAGE="https://daniel.haxx.se/blog/2023/04/03/introducing-trurl/ https://github.com/curl/trurl"
+HOMEPAGE="https://curl.se/trurl/ https://daniel.haxx.se/blog/2023/04/03/introducing-trurl/"
if [[ ${PV} == 9999 ]] ; then
EGIT_REPO_URI="https://github.com/curl/trurl"
@@ -25,7 +25,12 @@ RESTRICT="!test? ( test )"
DEPEND=">=net-misc/curl-7.62.0"
RDEPEND="${DEPEND}"
-BDEPEND="test? ( dev-lang/perl )"
+BDEPEND="
+ test? (
+ dev-lang/perl
+ virtual/perl-JSON-PP
+ )
+"
src_compile() {
tc-export CC