summaryrefslogtreecommitdiff
path: root/net-misc/trurl/trurl-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-18 11:55:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-18 11:55:01 +0100
commit7288c6e5fa05acddbf692a5187d925ef85662b46 (patch)
tree54bfc06561e59d1ad1e6e7bdbd06b76fc4ba0d06 /net-misc/trurl/trurl-9999.ebuild
parent5a1fb66df455454109e1de61d38b48f509dc68b8 (diff)
gentoo auto-resync : 18:04:2023 - 11:55:01
Diffstat (limited to 'net-misc/trurl/trurl-9999.ebuild')
-rw-r--r--net-misc/trurl/trurl-9999.ebuild22
1 files changed, 15 insertions, 7 deletions
diff --git a/net-misc/trurl/trurl-9999.ebuild b/net-misc/trurl/trurl-9999.ebuild
index 78443cfb2991..fe0c58e18fdd 100644
--- a/net-misc/trurl/trurl-9999.ebuild
+++ b/net-misc/trurl/trurl-9999.ebuild
@@ -3,7 +3,8 @@
EAPI=8
-inherit toolchain-funcs
+PYTHON_COMPAT=( python3_{9..11} )
+inherit toolchain-funcs python-any-r1
DESCRIPTION="Command line tool for URL parsing and manipulation"
HOMEPAGE="https://curl.se/trurl/ https://daniel.haxx.se/blog/2023/04/03/introducing-trurl/"
@@ -26,12 +27,15 @@ RESTRICT="!test? ( test )"
# Older curls may work but not all features will be present
DEPEND=">=net-misc/curl-7.81.0"
RDEPEND="${DEPEND}"
-BDEPEND="
- test? (
- dev-lang/perl
- virtual/perl-JSON-PP
- )
-"
+BDEPEND="test? ( ${PYTHON_DEPS} )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.5-fix-makefile.patch
+)
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
src_compile() {
tc-export CC
@@ -39,6 +43,10 @@ src_compile() {
default
}
+src_test() {
+ emake PYTHON3="${EPYTHON}" test
+}
+
src_install() {
emake DESTDIR="${D}" PREFIX="${EPREFIX}"/usr install
}