summaryrefslogtreecommitdiff
path: root/net-misc/trurl/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-18 11:55:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-18 11:55:01 +0100
commit7288c6e5fa05acddbf692a5187d925ef85662b46 (patch)
tree54bfc06561e59d1ad1e6e7bdbd06b76fc4ba0d06 /net-misc/trurl/files
parent5a1fb66df455454109e1de61d38b48f509dc68b8 (diff)
gentoo auto-resync : 18:04:2023 - 11:55:01
Diffstat (limited to 'net-misc/trurl/files')
-rw-r--r--net-misc/trurl/files/trurl-0.5-fix-makefile.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/net-misc/trurl/files/trurl-0.5-fix-makefile.patch b/net-misc/trurl/files/trurl-0.5-fix-makefile.patch
new file mode 100644
index 000000000000..66a152991ca4
--- /dev/null
+++ b/net-misc/trurl/files/trurl-0.5-fix-makefile.patch
@@ -0,0 +1,22 @@
+See https://github.com/curl/trurl/pull/158#issuecomment-1512397801.
+--- a/Makefile
++++ b/Makefile
+@@ -1,8 +1,6 @@
+ TARGET = trurl
+ OBJS = trurl.o
+-LDLIBS != curl-config --libs
+-CFLAGS != curl-config --cflags
+-CFLAGS += -W -Wall -pedantic -g
++LDLIBS = $(shell curl-config --libs)
+ MANUAL = trurl.1
+
+ PREFIX ?= /usr/local
+@@ -13,7 +11,7 @@ INSTALL ?= install
+ PYTHON3 ?= python3
+
+ $(TARGET): $(OBJS)
+- $(CC) $(OBJS) -o $(TARGET) $(LDLIBS) $(LDFLAGS)
++ $(CC) $(CPPFLAGS) $(CFLAGS) -Wall $(shell curl-config --cflags) $(LDFLAGS) $(OBJS) -o $(TARGET) $(LDLIBS)
+
+ trurl.o:trurl.c version.h
+