summaryrefslogtreecommitdiff
path: root/net-misc/trurl/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-31 09:23:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-31 09:23:01 +0100
commit441510fa20665b7920b149994e72b3a1cd62a813 (patch)
tree4bc2e347ca49e5da4915fc3c117c0db31b0ac6cd /net-misc/trurl/files
parent3810dd6a469ba3e0014a390d92f1fc220dd20c3b (diff)
gentoo auto-resync : 31:05:2023 - 09:23:01
Diffstat (limited to 'net-misc/trurl/files')
-rw-r--r--net-misc/trurl/files/trurl-0.7-fix-makefile.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/net-misc/trurl/files/trurl-0.7-fix-makefile.patch b/net-misc/trurl/files/trurl-0.7-fix-makefile.patch
new file mode 100644
index 000000000000..f1ecb28d3aaa
--- /dev/null
+++ b/net-misc/trurl/files/trurl-0.7-fix-makefile.patch
@@ -0,0 +1,21 @@
+See https://github.com/curl/trurl/pull/158#issuecomment-1512397801.
+--- a/Makefile
++++ b/Makefile
+@@ -1,7 +1,6 @@
+ TARGET = trurl
+ OBJS = trurl.o
+-LDLIBS = $$(curl-config --libs)
+-CFLAGS = $$(curl-config --cflags) -W -Wall -Wshadow -Werror -pedantic -g
++LDLIBS = $(shell curl-config --libs)
+ MANUAL = trurl.1
+
+ PREFIX ?= /usr/local
+@@ -12,7 +11,7 @@ INSTALL ?= install
+ PYTHON3 ?= python3
+
+ $(TARGET): $(OBJS)
+- $(CC) $(OBJS) -o $(TARGET) $(LDLIBS) $(LDFLAGS)
++ $(CC) $(CPPFLAGS) $(CFLAGS) -Wall $(shell curl-config --cflags) $(LDFLAGS) $(OBJS) -o $(TARGET) $(LDLIBS)
+
+ trurl.o:trurl.c version.h
+