summaryrefslogtreecommitdiff
path: root/net-misc/tiers/tiers-1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-misc/tiers/tiers-1.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-misc/tiers/tiers-1.1.ebuild')
-rw-r--r--net-misc/tiers/tiers-1.1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/net-misc/tiers/tiers-1.1.ebuild b/net-misc/tiers/tiers-1.1.ebuild
new file mode 100644
index 000000000000..fc8a2d38b9dc
--- /dev/null
+++ b/net-misc/tiers/tiers-1.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit eutils
+
+MY_P="${PN}${PV}"
+DESCRIPTION="Random network topography generator"
+HOMEPAGE="http://www.isi.edu/nsnam/ns/ns-topogen.html#tiers"
+SRC_URI="http://www.isi.edu/nsnam/dist/topogen/${MY_P}.tar.gz
+ http://www.isi.edu/nsnam/dist/topogen/tiers2ns-lan.awk"
+
+LICENSE="mapm"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc x86"
+IUSE=""
+
+DEPEND="sys-devel/gcc"
+RDEPEND="virtual/awk
+ sci-visualization/gnuplot"
+
+S=${WORKDIR}/${PN}${PV}
+
+src_unpack() {
+ unpack ${MY_P}.tar.gz
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${MY_P}-gccfixes.patch
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+ sed -e '1a\#!/bin/sh' -e '1d' -e "s|-f |-f /usr/share/${PN}/|g" -i "${S}"/bin/strip4gnuplot3.5
+}
+
+src_compile() {
+ cd "${S}"/src
+ emake CFLAGS="${CFLAGS}" CONFIGFILE="/etc/tiers-gnuplot.conf" EXEC="../bin/tiers-gnuplot" || die
+ # cleanup for a sec
+ rm *.o
+ emake CFLAGS="${CFLAGS}" CONFIGFILE="/etc/tiers.conf" EXEC="../bin/tiers" || die
+}
+
+src_install() {
+ dobin bin/tiers bin/tiers-gnuplot bin/strip4gnuplot3.5
+ insinto /etc
+ newins src/tiers_config.generic tiers.conf
+ newins src/tiers_config.gnuplot tiers-gnuplot.conf
+ insinto /usr/share/${PN}
+ doins bin/*.awk "${DISTDIR}"/tiers2ns-lan.awk
+ dodoc CHANGES COPYRIGHT README docs/*
+}