summaryrefslogtreecommitdiff
path: root/net-misc/telnet-bsd/telnet-bsd-1.2-r4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-15 19:43:32 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-15 19:43:32 +0100
commitfa1962ff69701bd9c0f15fb225cdbfb487125e0e (patch)
tree85b35bd5a3c73ea562768237a25da176adef5744 /net-misc/telnet-bsd/telnet-bsd-1.2-r4.ebuild
parentbd8ca999980e9c0c9ae40a11789c858bb58769e3 (diff)
gentoo auto-resync : 15:07:2022 - 19:43:32
Diffstat (limited to 'net-misc/telnet-bsd/telnet-bsd-1.2-r4.ebuild')
-rw-r--r--net-misc/telnet-bsd/telnet-bsd-1.2-r4.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/net-misc/telnet-bsd/telnet-bsd-1.2-r4.ebuild b/net-misc/telnet-bsd/telnet-bsd-1.2-r4.ebuild
new file mode 100644
index 000000000000..890dc085eabe
--- /dev/null
+++ b/net-misc/telnet-bsd/telnet-bsd-1.2-r4.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="Telnet and telnetd ported from OpenBSD with IPv6 support"
+HOMEPAGE="ftp://ftp.suse.com/pub/people/kukuk/ipv6/"
+SRC_URI="https://dev.gentoo.org/~mschiff/distfiles/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="nls xinetd"
+
+DEPEND="
+ sys-libs/ncurses:=
+ !net-misc/netkit-telnetd
+"
+RDEPEND="${DEPEND}
+ xinetd? ( sys-apps/xinetd )
+ !net-misc/netkit-telnetd
+"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-fbsd.patch
+ "${FILESDIR}"/${PN}-1.2-format-security.patch
+ "${FILESDIR}"/${P}-musl.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_compile() {
+ emake LIBS="$("$(tc-getPKG_CONFIG)" --libs ncurses)"
+}
+
+src_install() {
+ default
+
+ if use xinetd ; then
+ insinto /etc/xinetd.d
+ newins "${FILESDIR}"/telnetd.xinetd telnetd
+ fi
+}