summaryrefslogtreecommitdiff
path: root/net-misc/taylor-uucp/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /net-misc/taylor-uucp/files
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'net-misc/taylor-uucp/files')
-rw-r--r--net-misc/taylor-uucp/files/taylor-uucp-1.07-gentoo.patch10
-rw-r--r--net-misc/taylor-uucp/files/taylor-uucp-1.07-remove-extern.patch67
2 files changed, 71 insertions, 6 deletions
diff --git a/net-misc/taylor-uucp/files/taylor-uucp-1.07-gentoo.patch b/net-misc/taylor-uucp/files/taylor-uucp-1.07-gentoo.patch
index 42839bab300c..86af851a9020 100644
--- a/net-misc/taylor-uucp/files/taylor-uucp-1.07-gentoo.patch
+++ b/net-misc/taylor-uucp/files/taylor-uucp-1.07-gentoo.patch
@@ -1,6 +1,5 @@
-diff -Nru uucp-1.07.orig/Makefile.am uucp-1.07/Makefile.am
---- uucp-1.07.orig/Makefile.am 2003-05-30 00:10:23.000000000 +0000
-+++ uucp-1.07/Makefile.am 2009-03-06 18:41:48.000000000 +0000
+--- a/Makefile.am 2003-05-30 00:10:23.000000000 +0000
++++ b/Makefile.am 2009-03-06 18:41:48.000000000 +0000
@@ -78,12 +78,12 @@
install-exec-hook:
@@ -18,9 +17,8 @@ diff -Nru uucp-1.07.orig/Makefile.am uucp-1.07/Makefile.am
done
if HAVE_MKDIR
else
-diff -Nru uucp-1.07.orig/policy.h uucp-1.07/policy.h
---- uucp-1.07.orig/policy.h 2003-05-29 06:08:45.000000000 +0000
-+++ uucp-1.07/policy.h 2009-03-06 18:41:48.000000000 +0000
+--- a/policy.h 2003-05-29 06:08:45.000000000 +0000
++++ b/policy.h 2009-03-06 18:41:48.000000000 +0000
@@ -302,8 +302,7 @@
/* #define LOCKDIR "/usr/spool/locks" */
/* #define LOCKDIR "/usr/spool/uucp/LCK" */
diff --git a/net-misc/taylor-uucp/files/taylor-uucp-1.07-remove-extern.patch b/net-misc/taylor-uucp/files/taylor-uucp-1.07-remove-extern.patch
new file mode 100644
index 000000000000..4a8efeeb83f3
--- /dev/null
+++ b/net-misc/taylor-uucp/files/taylor-uucp-1.07-remove-extern.patch
@@ -0,0 +1,67 @@
+From 84b5bf1e6b8cfad657b88f8b061e172e327ef970 Mon Sep 17 00:00:00 2001
+From: Nicolas Boichat <drinkcat@chromium.org>
+Date: Thu, 10 Sep 2020 17:06:37 +0800
+Subject: [PATCH] Remove external function declarations
+
+We need to redeclare functions that we already have.
+
+This causes issues with recent toolchains:
+init.c:100:14: error: redeclaration of 'getcwd' must have the 'overloadable' attribute
+extern char *getcwd ();
+ ^
+/build/amd64-generic/usr/include/bits/unistd.h:158:8: note: previous overload of function is here
+__NTH (getcwd (char *const __clang_pass_object_size __buf, size_t __size))
+ ^
+
+And also reduces the number of build warnings.
+
+This forked repo does the same thing in this (large) cleanup patch:
+https://github.com/quinot/taylor-uucp/commit/b599665ae1e085df0f96de5f50a738fceee02150
+---
+ unix/init.c | 30 ------------------------------
+ 1 file changed, 30 deletions(-)
+
+diff --git a/unix/init.c b/unix/init.c
+index d9d2147edd93..a9b7135be9f4 100644
+--- a/unix/init.c
++++ b/unix/init.c
+@@ -81,36 +81,6 @@
+ #endif /* ! defined (MAXPATHLEN) */
+ #endif /* HAVE_GETWD */
+
+-/* External functions. */
+-#ifndef getlogin
+-extern char *getlogin ();
+-#endif
+-#if GETPWNAM_DECLARATION_OK
+-#ifndef getpwnam
+-extern struct passwd *getpwnam ();
+-#endif
+-#endif
+-#if GETPWUID_DECLARATION_OK
+-#ifndef getpwuid
+-extern struct passwd *getpwuid ();
+-#endif
+-#endif
+-#if HAVE_GETCWD
+-#ifndef getcwd
+-extern char *getcwd ();
+-#endif
+-#endif
+-#if HAVE_GETWD
+-#ifndef getwd
+-extern char *getwd ();
+-#endif
+-#endif
+-#if HAVE_SYSCONF
+-#ifndef sysconf
+-extern long sysconf ();
+-#endif
+-#endif
+-
+ /* Initialize the system dependent routines. We will probably be running
+ suid to uucp, so we make sure that nothing is obviously wrong. We
+ save the login name since we will be losing the real uid. */
+--
+2.28.0.526.ge36021eeef-goog
+