summaryrefslogtreecommitdiff
path: root/net-misc/sysrepo/sysrepo-2.1.64.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /net-misc/sysrepo/sysrepo-2.1.64.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'net-misc/sysrepo/sysrepo-2.1.64.ebuild')
-rw-r--r--net-misc/sysrepo/sysrepo-2.1.64.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-misc/sysrepo/sysrepo-2.1.64.ebuild b/net-misc/sysrepo/sysrepo-2.1.64.ebuild
new file mode 100644
index 000000000000..86607e642736
--- /dev/null
+++ b/net-misc/sysrepo/sysrepo-2.1.64.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="YANG-based configuration and operational state data store"
+HOMEPAGE="https://www.sysrepo.org"
+SRC_URI="https://github.com/sysrepo/sysrepo/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=net-libs/libyang-2.0.194"
+DEPEND="${RDEPEND}"
+BDEPEND="doc? ( app-doc/doxygen[dot] )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_TESTS=$(usex test)
+ -DENABLE_VALGRIND_TESTS=OFF
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+
+ use doc && cmake_src_compile doc
+}
+
+src_install() {
+ cmake_src_install
+
+ use doc && dodoc -r doc/.
+}