summaryrefslogtreecommitdiff
path: root/net-misc/switzerland/switzerland-0.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-misc/switzerland/switzerland-0.1.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-misc/switzerland/switzerland-0.1.0.ebuild')
-rw-r--r--net-misc/switzerland/switzerland-0.1.0.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/net-misc/switzerland/switzerland-0.1.0.ebuild b/net-misc/switzerland/switzerland-0.1.0.ebuild
new file mode 100644
index 000000000000..2ff94e8d6285
--- /dev/null
+++ b/net-misc/switzerland/switzerland-0.1.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 toolchain-funcs
+
+DESCRIPTION="Network Testing Tool"
+HOMEPAGE="http://www.eff.org/testyourisp/switzerland/"
+SRC_URI="mirror://sourceforge/switzerland/${P}.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+DEPEND="net-libs/libpcap"
+RDEPEND=${DEPEND}
+
+src_prepare() {
+ cp "${FILESDIR}"/Makefile switzerland/client
+
+ sed -i \
+ -e "s/= find_binary()/= dest/" \
+ setup.py
+ distutils-r1_src_prepare
+}
+
+src_compile() {
+ cd switzerland/client
+ emake CC=$(tc-getCC)
+
+ cd "${S}"
+ distutils-r1_src_compile
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ dodoc BUGS.txt CREDITS
+
+ keepdir /var/log/switzerland-pcaps
+ keepdir /var/log/switzerland
+}