summaryrefslogtreecommitdiff
path: root/net-misc/stuntman/stuntman-1.2.16.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-11-03 06:47:15 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-11-03 06:47:15 +0000
commitfc2f1018fc323ef2c6572734a9b130427cba76a6 (patch)
treef834bdc9a67923ce75297c09d00d1e7b90791d26 /net-misc/stuntman/stuntman-1.2.16.ebuild
parent162945d2a91899b637bbb9e163b406350de12906 (diff)
gentoo resync : 03.11.2021
Diffstat (limited to 'net-misc/stuntman/stuntman-1.2.16.ebuild')
-rw-r--r--net-misc/stuntman/stuntman-1.2.16.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-misc/stuntman/stuntman-1.2.16.ebuild b/net-misc/stuntman/stuntman-1.2.16.ebuild
new file mode 100644
index 000000000000..6cf500907066
--- /dev/null
+++ b/net-misc/stuntman/stuntman-1.2.16.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Open source implementation of the STUN protocol"
+HOMEPAGE="http://www.stunprotocol.org"
+SRC_URI="http://www.stunprotocol.org/stunserver-${PV}.tgz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-libs/openssl:0=
+"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+"
+
+S="${WORKDIR}/stunserver"
+
+src_compile() {
+ tc-export AR CXX
+
+ emake T=""
+}
+
+src_test() {
+ ./stuntestcode || die
+}
+
+src_install() {
+ dobin stunclient
+ dosbin stunserver
+ dodoc HISTORY README
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+}