summaryrefslogtreecommitdiff
path: root/net-misc/streamlink
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-02-16 12:59:29 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-02-16 12:59:29 +0000
commit79599515788b85b18aa655e7b7f8cc05c1bbddd8 (patch)
treeade7cb031f363fad64c77139dea7aa3d81908537 /net-misc/streamlink
parent6bc2e4d7c5906e46a8f275a876ead6ec41aca5bb (diff)
gentoo resync : 16.02.1018
Diffstat (limited to 'net-misc/streamlink')
-rw-r--r--net-misc/streamlink/Manifest2
-rw-r--r--net-misc/streamlink/streamlink-1.0.0.ebuild71
2 files changed, 73 insertions, 0 deletions
diff --git a/net-misc/streamlink/Manifest b/net-misc/streamlink/Manifest
index 1c50cb59d755..da7bb25925f6 100644
--- a/net-misc/streamlink/Manifest
+++ b/net-misc/streamlink/Manifest
@@ -1,4 +1,6 @@
DIST streamlink-0.14.2.tar.gz 643695 BLAKE2B ea28daac32903738206226bce85a4615338b6039be1e4cce18325e977112c3301d6e6ed90d1210f4f362c898397fd980c136a98d8a0d5ff7ee2b6c5cf077f2c6 SHA512 0d9f1db32915392f9d29bcfb40743058352a924435a8ee77f1218c108e937204e88041c908d2f93546beaa70e18db62c961ea31fbdd85c5e7e4315a18118e276
+DIST streamlink-1.0.0.tar.gz 674393 BLAKE2B 091272bae71f1e89cf14872578091a01f9d05ee372d4b9379e672280735c6800a33ae198bf019fbb3e970aa060ef059e5106e1be3a20602874be6206b6303bf6 SHA512 22ba96ac0ec27fe923b99898c45548df88ed3dda3bcbcb10b55fea145e20731eb8aa3a90212a5863b4ef5a7387d4bcf3d09d447ea2789762a8cf5eaa87f263d7
EBUILD streamlink-0.14.2-r1.ebuild 1873 BLAKE2B d65929f452d2263b895ed0fd7f0299ee045d649efff7f95e95e88460f262f5a6ca9db1ac20316704a67726e8b7c6c513a69259638f57d64e66ed01872d7068cf SHA512 98a52a9ead5700b82281343bca40bc010303e63be8961cdaa8eb29b68a328e8d233272a2b93cb6d6405a25da7b0092532011eb900c8272f591b42603ef5599f2
+EBUILD streamlink-1.0.0.ebuild 2020 BLAKE2B b54353585e6d6a9cd2b22895ba5dddaf0a516b4c7bb1e7a1c125ad2db477b1701c083f97cca83dd5db4802c5dde4d0e2561bc61134d7526112090c2e5c81ccd2 SHA512 b981253ca0f621eabe90e7e92c19f7e2f089ec215514209aaf8176daa5daa4bbdb9ae9ab2cdbc06765e6f9524c2c387864e155610898204915ebf01079ddaece
EBUILD streamlink-9999.ebuild 1546 BLAKE2B 034d354005c4e72d769bc33de4068aa537d239050a64b83c3c260662ee1609d80a478fcb58bf42a94a50224e43a16ca2972d6ac7a2e9f31d54ddc1a643f5a235 SHA512 3c5f51958877bd15cd3c5f82c42c076bd8ff1ff52102702508d48a746b03b955520bccc14dbd13b80688f1824e68f79fb5a6fba565847a07e553bf42eb94b554
MISC metadata.xml 330 BLAKE2B ad3caca1dc3dd2ea5915a6d14f9741ba7352d8a961939dacf89efdcae0cf1203343ca11ea230efc30cf69d359e09e7cd06218404943f8e4e3853a5c6676f7ff6 SHA512 73730cc94810711b86088a41beba0d0da4f20c4ca377c24122ebeac1ea68e712d03d0e79518df847aa15cb9d8a3f04658715f0b75dfaa1a6dfbedc0a15c33672
diff --git a/net-misc/streamlink/streamlink-1.0.0.ebuild b/net-misc/streamlink/streamlink-1.0.0.ebuild
new file mode 100644
index 000000000000..07f15c0c5a65
--- /dev/null
+++ b/net-misc/streamlink/streamlink-1.0.0.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+PYTHON_REQ_USE='xml(+),threads(+)'
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1
+
+DESCRIPTION="CLI for extracting streams from websites to a video player of your choice"
+HOMEPAGE="https://streamlink.github.io/"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="BSD-2 Apache-2.0"
+SLOT="0"
+IUSE="doc test"
+
+# >=urllib3-1.23 only needed for python2, but requests pulls some version anyways, so we might as well guarantee at least that ver for py3 too
+RDEPEND="
+ virtual/python-futures[${PYTHON_USEDEP}]
+ virtual/python-singledispatch[${PYTHON_USEDEP}]
+ >dev-python/requests-2.21.0[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.23[${PYTHON_USEDEP}]
+ dev-python/isodate[${PYTHON_USEDEP}]
+ dev-python/websocket-client[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/backports-shutil_which[${PYTHON_USEDEP}]' 'python2*')
+ $(python_gen_cond_dep 'dev-python/backports-shutil_get_terminal_size[${PYTHON_USEDEP}]' 'python2*')
+ dev-python/pycountry[${PYTHON_USEDEP}]
+ >=dev-python/pycryptodome-3.4.3[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/recommonmark[${PYTHON_USEDEP}]
+ )
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ )"
+RDEPEND="${RDEPEND}
+ media-video/rtmpdump
+ virtual/ffmpeg
+"
+
+python_configure_all() {
+ # Avoid iso-639, iso3166 dependencies since we use pycountry.
+ export STREAMLINK_USE_PYCOUNTRY=1
+}
+
+python_compile_all() {
+ use doc && emake -C docs html man
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ if use doc; then
+ local HTML_DOCS=( docs/_build/html/. )
+ doman docs/_build/man/*
+ fi
+ distutils-r1_python_install_all
+}