summaryrefslogtreecommitdiff
path: root/net-misc/streamlink
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-16 05:56:39 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-16 05:56:39 +0000
commit433cb2e828d414c74b16d429f40d25e179b0a70f (patch)
treeaf337fbb3c6591c911ea3b25ff43883e9144b506 /net-misc/streamlink
parent038c98389fa5a5efb22cffaa35ecdddfc9a38036 (diff)
gentoo auto-resync : 16:01:2023 - 05:56:39
Diffstat (limited to 'net-misc/streamlink')
-rw-r--r--net-misc/streamlink/Manifest4
-rw-r--r--net-misc/streamlink/streamlink-5.1.2.ebuild56
-rw-r--r--net-misc/streamlink/streamlink-9999.ebuild5
3 files changed, 63 insertions, 2 deletions
diff --git a/net-misc/streamlink/Manifest b/net-misc/streamlink/Manifest
index 3160355b7e0d..e7cde6a4c67f 100644
--- a/net-misc/streamlink/Manifest
+++ b/net-misc/streamlink/Manifest
@@ -1,4 +1,6 @@
DIST streamlink-4.3.0.tar.gz 474184 BLAKE2B 557d70105f043fe7454d1c6dd7a49becfd354612df43d09242ec86da5275c7c629f6df887ee7e3a25d9c502e0845f38bece0da2335c5f09951cb4b0aada408a3 SHA512 e1c450d777c00515c07895303dccdece23a8a29b2f9cc272790f5d4b260adbb381845d7ffbc9425e6cee7be41d66158e226d14d08352430bff1c29889b0b0077
+DIST streamlink-5.1.2.tar.gz 494342 BLAKE2B f916aab0fcd346e9945de04335309c61cb83c7c5047208a281a87162fb19dae6e45ae861fbc55780049e63bd854f303ee1669d3664a3736debbf8194ee4e6760 SHA512 8fecdc46fc34b37a5a67d15bb4252d1ebab69815398deb533de063fdf7e211d23d413b1b519984dddd2bb5e35296d717dd0504a3578b7bc44c7b123cd70db2a3
EBUILD streamlink-4.3.0.ebuild 1395 BLAKE2B dba4163937369a5b50311ee57103cfe1408a857a93066a9881df0e4ef8c18b446df215904b7a1b713800272aac2ff201be5d98fe1142e218c676506d3c2d73c5 SHA512 b41080cc87d8f70c2ee6514a3407b83d55f583e82df31b8229d08f682021343fe9ca6e02c16a91cadfefcafd19fdfc0377450b6503ef880d05906f08d868d47e
-EBUILD streamlink-9999.ebuild 1395 BLAKE2B dba4163937369a5b50311ee57103cfe1408a857a93066a9881df0e4ef8c18b446df215904b7a1b713800272aac2ff201be5d98fe1142e218c676506d3c2d73c5 SHA512 b41080cc87d8f70c2ee6514a3407b83d55f583e82df31b8229d08f682021343fe9ca6e02c16a91cadfefcafd19fdfc0377450b6503ef880d05906f08d868d47e
+EBUILD streamlink-5.1.2.ebuild 1529 BLAKE2B 958bfa808f760c61033d8bc314c2d457cbe40ab4f9453cadaf7d9ee8d23a64562a3a9ead3f5ac24516e147c69f1194dfdbdf0125d2af701a9eb87012ad1c7c87 SHA512 5e380040120a622ca487250b539b134e05fc717a234d9bc1d207c14d7e53414bff72c53bc5c378363ac860d3d437789c0baf2e65469dee4ea0ac92ba43ba598d
+EBUILD streamlink-9999.ebuild 1529 BLAKE2B 958bfa808f760c61033d8bc314c2d457cbe40ab4f9453cadaf7d9ee8d23a64562a3a9ead3f5ac24516e147c69f1194dfdbdf0125d2af701a9eb87012ad1c7c87 SHA512 5e380040120a622ca487250b539b134e05fc717a234d9bc1d207c14d7e53414bff72c53bc5c378363ac860d3d437789c0baf2e65469dee4ea0ac92ba43ba598d
MISC metadata.xml 379 BLAKE2B 21a218ca77644378c3f697dc3fa4419cdaa9c45a39412d8dcace6b84d15a3aca6e835fd664fbcc6ee894a041b5513f0253d59b9d4529380782c92b1e3f7bef8f SHA512 f1d9151410ce62fff5c475f648c6b17d360def428ebf464282019672b4acf2efe0abfc03b8207417ba741c897a1e7b7789426e5f133ac57826f82b12ef39939c
diff --git a/net-misc/streamlink/streamlink-5.1.2.ebuild b/net-misc/streamlink/streamlink-5.1.2.ebuild
new file mode 100644
index 000000000000..ff7c51d0ed88
--- /dev/null
+++ b/net-misc/streamlink/streamlink-5.1.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/streamlink/${PN}.git"
+ inherit git-r3
+fi
+
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE='xml(+),threads(+)'
+inherit distutils-r1
+
+DESCRIPTION="CLI for extracting streams from websites to a video player of your choice"
+HOMEPAGE="https://streamlink.github.io/"
+
+if [[ ${PV} != 9999* ]]; then
+ SRC_URI="https://github.com/streamlink/${PN}/releases/download/${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD-2 Apache-2.0"
+SLOT="0"
+
+DEPEND="
+ $(python_gen_cond_dep '
+ dev-python/certifi[${PYTHON_USEDEP}]
+ >dev-python/requests-2.21.0[${PYTHON_USEDEP}]
+ dev-python/isodate[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.6.4[${PYTHON_USEDEP}]
+ dev-python/websocket-client[${PYTHON_USEDEP}]
+ dev-python/pycountry[${PYTHON_USEDEP}]
+ >=dev-python/pycryptodome-3.4.3[${PYTHON_USEDEP}]
+ >dev-python/PySocks-1.5.7[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.26.0[${PYTHON_USEDEP}]
+ >=dev-python/versioningit-2.0.0[${PYTHON_USEDEP}]
+ ')
+"
+RDEPEND="${DEPEND}
+ media-video/ffmpeg
+"
+BDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/versioningit-2.0.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ >=dev-python/freezegun-1.0.0[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ )
+ ')"
+
+distutils_enable_tests pytest
diff --git a/net-misc/streamlink/streamlink-9999.ebuild b/net-misc/streamlink/streamlink-9999.ebuild
index db619ea9b999..ff7c51d0ed88 100644
--- a/net-misc/streamlink/streamlink-9999.ebuild
+++ b/net-misc/streamlink/streamlink-9999.ebuild
@@ -27,6 +27,7 @@ SLOT="0"
DEPEND="
$(python_gen_cond_dep '
+ dev-python/certifi[${PYTHON_USEDEP}]
>dev-python/requests-2.21.0[${PYTHON_USEDEP}]
dev-python/isodate[${PYTHON_USEDEP}]
>=dev-python/lxml-4.6.4[${PYTHON_USEDEP}]
@@ -34,6 +35,7 @@ DEPEND="
dev-python/pycountry[${PYTHON_USEDEP}]
>=dev-python/pycryptodome-3.4.3[${PYTHON_USEDEP}]
>dev-python/PySocks-1.5.7[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.26.0[${PYTHON_USEDEP}]
>=dev-python/versioningit-2.0.0[${PYTHON_USEDEP}]
')
"
@@ -45,8 +47,9 @@ BDEPEND="
>=dev-python/versioningit-2.0.0[${PYTHON_USEDEP}]
test? (
dev-python/mock[${PYTHON_USEDEP}]
- dev-python/requests-mock[${PYTHON_USEDEP}]
>=dev-python/freezegun-1.0.0[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
)
')"