summaryrefslogtreecommitdiff
path: root/net-misc/streamlink/streamlink-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-10 21:05:55 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-10 21:05:55 +0000
commit71deace00d1a2b091313fe137ab7092418c6f87c (patch)
tree9f1f0dee23e13658e52f49437befe78427148c51 /net-misc/streamlink/streamlink-9999.ebuild
parent29aabba0ea759c6a2864ff5631735b67ee38e5e0 (diff)
gentoo resync : 10.02.2020
Diffstat (limited to 'net-misc/streamlink/streamlink-9999.ebuild')
-rw-r--r--net-misc/streamlink/streamlink-9999.ebuild42
1 files changed, 23 insertions, 19 deletions
diff --git a/net-misc/streamlink/streamlink-9999.ebuild b/net-misc/streamlink/streamlink-9999.ebuild
index 04417d2b4e75..28994a6a0f82 100644
--- a/net-misc/streamlink/streamlink-9999.ebuild
+++ b/net-misc/streamlink/streamlink-9999.ebuild
@@ -30,31 +30,35 @@ RESTRICT="!test? ( test )"
# >=urllib3-1.23 only needed for python2, but requests pulls some version anyways, so we might as well guarantee at least that ver for py3 too
DEPEND="
- virtual/python-futures[${PYTHON_USEDEP}]
- virtual/python-singledispatch[${PYTHON_USEDEP}]
- >dev-python/requests-2.21.0[${PYTHON_USEDEP}]
- >=dev-python/urllib3-1.23[${PYTHON_USEDEP}]
- dev-python/isodate[${PYTHON_USEDEP}]
- dev-python/websocket-client[${PYTHON_USEDEP}]
- dev-python/pycountry[${PYTHON_USEDEP}]
- >=dev-python/pycryptodome-3.4.3[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ virtual/python-futures[${PYTHON_MULTI_USEDEP}]
+ virtual/python-singledispatch[${PYTHON_MULTI_USEDEP}]
+ >dev-python/requests-2.21.0[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/urllib3-1.23[${PYTHON_MULTI_USEDEP}]
+ dev-python/isodate[${PYTHON_MULTI_USEDEP}]
+ dev-python/websocket-client[${PYTHON_MULTI_USEDEP}]
+ dev-python/pycountry[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/pycryptodome-3.4.3[${PYTHON_MULTI_USEDEP}]
+ ')
"
RDEPEND="${DEPEND}
media-video/rtmpdump
virtual/ffmpeg
"
BDEPEND="
- doc? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/docutils[${PYTHON_USEDEP}]
- dev-python/recommonmark[${PYTHON_USEDEP}]
- )
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/requests-mock[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/freezegun[${PYTHON_USEDEP}]
- )"
+ $(python_gen_cond_dep '
+ doc? (
+ dev-python/sphinx[${PYTHON_MULTI_USEDEP}]
+ dev-python/docutils[${PYTHON_MULTI_USEDEP}]
+ dev-python/recommonmark[${PYTHON_MULTI_USEDEP}]
+ )
+ test? (
+ dev-python/mock[${PYTHON_MULTI_USEDEP}]
+ dev-python/requests-mock[${PYTHON_MULTI_USEDEP}]
+ dev-python/pytest[${PYTHON_MULTI_USEDEP}]
+ dev-python/freezegun[${PYTHON_MULTI_USEDEP}]
+ )
+ ')"
python_configure_all() {
# Avoid iso-639, iso3166 dependencies since we use pycountry.