summaryrefslogtreecommitdiff
path: root/net-misc/streamlink/streamlink-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-23 20:48:53 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-23 20:48:53 +0000
commit51536d2fe4697ba9114d611178bb9e20d3d5b729 (patch)
tree30b91d98e65985a575940ed49e756697c1f049c2 /net-misc/streamlink/streamlink-9999.ebuild
parent4ab6db5717ef23f29320d4c6fb9ebdb8dec1f193 (diff)
gentoo resync : 23.12.2017
Diffstat (limited to 'net-misc/streamlink/streamlink-9999.ebuild')
-rw-r--r--net-misc/streamlink/streamlink-9999.ebuild15
1 files changed, 10 insertions, 5 deletions
diff --git a/net-misc/streamlink/streamlink-9999.ebuild b/net-misc/streamlink/streamlink-9999.ebuild
index 4a297db743e5..ff3f06dea73a 100644
--- a/net-misc/streamlink/streamlink-9999.ebuild
+++ b/net-misc/streamlink/streamlink-9999.ebuild
@@ -22,15 +22,20 @@ RDEPEND="dev-python/pycryptodome[${PYTHON_USEDEP}]
virtual/python-futures[${PYTHON_USEDEP}]
virtual/python-singledispatch[${PYTHON_USEDEP}]
dev-python/backports-shutil_which[$(python_gen_usedep 'python2*')]
- dev-python/backports-shutil_get_terminal_size[$(python_gen_usedep 'python2*')]
+ $(python_gen_cond_dep 'dev-python/backports-shutil_get_terminal_size[${PYTHON_USEDEP}]' 'python2*')
dev-python/pycountry[${PYTHON_USEDEP}]
+ dev-python/websocket-client[${PYTHON_USEDEP}]
media-video/rtmpdump
virtual/ffmpeg"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/docutils[${PYTHON_USEDEP}] )
- test? ( dev-python/mock[$(python_gen_usedep 'python2*')]
- ${RDEPEND} )"
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ )
+ test? (
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' 'python2*')
+ ${RDEPEND}
+ )"
python_configure_all() {
# Avoid iso-639, iso3166 dependencies since we use pycountry.