summaryrefslogtreecommitdiff
path: root/net-misc/streamlink/streamlink-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /net-misc/streamlink/streamlink-9999.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'net-misc/streamlink/streamlink-9999.ebuild')
-rw-r--r--net-misc/streamlink/streamlink-9999.ebuild42
1 files changed, 13 insertions, 29 deletions
diff --git a/net-misc/streamlink/streamlink-9999.ebuild b/net-misc/streamlink/streamlink-9999.ebuild
index 92c0803d4cf5..1f654f0ef9f0 100644
--- a/net-misc/streamlink/streamlink-9999.ebuild
+++ b/net-misc/streamlink/streamlink-9999.ebuild
@@ -1,74 +1,58 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
if [[ ${PV} = 9999* ]]; then
EGIT_REPO_URI="https://github.com/streamlink/${PN}.git"
- GIT_ECLASS="git-r3"
+ inherit git-r3
fi
-PYTHON_COMPAT=( python3_{8..9} )
-PYTHON_REQ_USE='xml(+),threads(+)'
DISTUTILS_SINGLE_IMPL=1
-inherit distutils-r1 ${GIT_ECLASS}
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE='xml(+),threads(+)'
+inherit distutils-r1
DESCRIPTION="CLI for extracting streams from websites to a video player of your choice"
HOMEPAGE="https://streamlink.github.io/"
if [[ ${PV} != 9999* ]]; then
SRC_URI="https://github.com/streamlink/${PN}/releases/download/${PV}/${P}.tar.gz"
- SRC_URI+=" https://dev.gentoo.org/~leio/distfiles/streamlink.1-${PV}.man.xz"
- KEYWORDS="~amd64 ~x86"
+ KEYWORDS="~amd64"
fi
LICENSE="BSD-2 Apache-2.0"
SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
DEPEND="
$(python_gen_cond_dep '
>dev-python/requests-2.21.0[${PYTHON_USEDEP}]
dev-python/isodate[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.6.4[${PYTHON_USEDEP}]
dev-python/websocket-client[${PYTHON_USEDEP}]
dev-python/pycountry[${PYTHON_USEDEP}]
>=dev-python/pycryptodome-3.4.3[${PYTHON_USEDEP}]
+ >dev-python/PySocks-1.5.7[${PYTHON_USEDEP}]
+ >=dev-python/versioningit-1.1.1[${PYTHON_USEDEP}]
')
"
RDEPEND="${DEPEND}
- media-video/rtmpdump
media-video/ffmpeg
"
BDEPEND="
$(python_gen_cond_dep '
+ dev-python/versioningit[${PYTHON_USEDEP}]
test? (
dev-python/mock[${PYTHON_USEDEP}]
dev-python/requests-mock[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
>=dev-python/freezegun-1.0.0[${PYTHON_USEDEP}]
)
')"
-src_prepare() {
- distutils-r1_src_prepare
- if [[ ${PV} != 9999* ]]; then
- mv "${WORKDIR}"/streamlink.1-${PV}.man "${WORKDIR}"/streamlink.1 || die
- fi
-}
+distutils_enable_tests pytest
python_configure_all() {
# Avoid iso-639, iso3166 dependencies since we use pycountry.
export STREAMLINK_USE_PYCOUNTRY=1
}
-
-python_test() {
- esetup.py test
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- if [[ ${PV} != 9999* ]]; then
- doman "${WORKDIR}"/streamlink.1
- fi
-}