summaryrefslogtreecommitdiff
path: root/net-misc/streamlink/streamlink-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-29 18:03:51 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-29 18:03:51 +0000
commitd7ed2b01311f15ba54fe8ea872aab7d59ab2b193 (patch)
tree1814dd2b5bbf2e7639fdafbeef48d228cfaf5e9b /net-misc/streamlink/streamlink-9999.ebuild
parentabaa75b10f899ada8dd05b23cc03205064394bc6 (diff)
gentoo resync : 29.01.2021
Diffstat (limited to 'net-misc/streamlink/streamlink-9999.ebuild')
-rw-r--r--net-misc/streamlink/streamlink-9999.ebuild32
1 files changed, 14 insertions, 18 deletions
diff --git a/net-misc/streamlink/streamlink-9999.ebuild b/net-misc/streamlink/streamlink-9999.ebuild
index e1b66ef0065e..43cd8b5f34a6 100644
--- a/net-misc/streamlink/streamlink-9999.ebuild
+++ b/net-misc/streamlink/streamlink-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -20,19 +20,18 @@ HOMEPAGE="https://streamlink.github.io/"
if [[ ${PV} != 9999* ]]; then
SRC_URI="https://github.com/streamlink/${PN}/releases/download/${PV}/${P}.tar.gz"
+ SRC_URI+=" https://dev.gentoo.org/~leio/distfiles/streamlink.1-${PV}.man.xz"
KEYWORDS="~amd64 ~x86"
fi
LICENSE="BSD-2 Apache-2.0"
SLOT="0"
-IUSE="doc test"
+IUSE="test"
RESTRICT="!test? ( test )"
-# >=urllib3-1.23 only needed for python2, but requests pulls some version anyways, so we might as well guarantee at least that ver for py3 too
DEPEND="
$(python_gen_cond_dep '
>dev-python/requests-2.21.0[${PYTHON_MULTI_USEDEP}]
- >=dev-python/urllib3-1.23[${PYTHON_MULTI_USEDEP}]
dev-python/isodate[${PYTHON_MULTI_USEDEP}]
dev-python/websocket-client[${PYTHON_MULTI_USEDEP}]
dev-python/pycountry[${PYTHON_MULTI_USEDEP}]
@@ -45,36 +44,33 @@ RDEPEND="${DEPEND}
"
BDEPEND="
$(python_gen_cond_dep '
- doc? (
- dev-python/sphinx[${PYTHON_MULTI_USEDEP}]
- dev-python/docutils[${PYTHON_MULTI_USEDEP}]
- dev-python/recommonmark[${PYTHON_MULTI_USEDEP}]
- )
test? (
dev-python/mock[${PYTHON_MULTI_USEDEP}]
dev-python/requests-mock[${PYTHON_MULTI_USEDEP}]
dev-python/pytest[${PYTHON_MULTI_USEDEP}]
- dev-python/freezegun[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/freezegun-1.0.0[${PYTHON_MULTI_USEDEP}]
)
')"
+src_prepare() {
+ distutils-r1_src_prepare
+ if [[ ${PV} != 9999* ]]; then
+ mv ${WORKDIR}/streamlink.1-${PV}.man ${WORKDIR}/streamlink.1 || die
+ fi
+}
+
python_configure_all() {
# Avoid iso-639, iso3166 dependencies since we use pycountry.
export STREAMLINK_USE_PYCOUNTRY=1
}
-python_compile_all() {
- use doc && emake -C docs html man
-}
-
python_test() {
esetup.py test
}
python_install_all() {
- if use doc; then
- local HTML_DOCS=( docs/_build/html/. )
- doman docs/_build/man/*
- fi
distutils-r1_python_install_all
+ if [[ ${PV} != 9999* ]]; then
+ doman ${WORKDIR}/streamlink.1
+ fi
}