summaryrefslogtreecommitdiff
path: root/net-misc/streamlink/streamlink-5.5.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-25 10:31:10 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-25 10:31:10 +0000
commit2900e684ae4bdce1f20652587728095cd01a30a1 (patch)
treedb7b5054b7d0de362a2960a0a7268ffc37b8e1f9 /net-misc/streamlink/streamlink-5.5.1.ebuild
parentff8c6e4babf1a2911b8d61b6bb7e80290355cb70 (diff)
gentoo auto-resync : 25:11:2023 - 10:31:10
Diffstat (limited to 'net-misc/streamlink/streamlink-5.5.1.ebuild')
-rw-r--r--net-misc/streamlink/streamlink-5.5.1.ebuild58
1 files changed, 0 insertions, 58 deletions
diff --git a/net-misc/streamlink/streamlink-5.5.1.ebuild b/net-misc/streamlink/streamlink-5.5.1.ebuild
deleted file mode 100644
index b7ef73d3b5e2..000000000000
--- a/net-misc/streamlink/streamlink-5.5.1.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-if [[ ${PV} = 9999* ]]; then
- EGIT_REPO_URI="https://github.com/streamlink/${PN}.git"
- inherit git-r3
-fi
-
-DISTUTILS_SINGLE_IMPL=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
-PYTHON_REQ_USE='xml(+),threads(+)'
-inherit distutils-r1
-
-DESCRIPTION="CLI for extracting streams from websites to a video player of your choice"
-HOMEPAGE="https://streamlink.github.io/"
-
-if [[ ${PV} != 9999* ]]; then
- SRC_URI="https://github.com/streamlink/${PN}/releases/download/${PV}/${P}.tar.gz"
- KEYWORDS="amd64 ~arm ~arm64 ~x86"
-fi
-
-LICENSE="BSD-2 Apache-2.0"
-SLOT="0"
-
-DEPEND="
- $(python_gen_cond_dep '
- dev-python/certifi[${PYTHON_USEDEP}]
- >dev-python/requests-2.21.0[${PYTHON_USEDEP}]
- dev-python/isodate[${PYTHON_USEDEP}]
- >=dev-python/lxml-4.6.4[${PYTHON_USEDEP}]
- dev-python/websocket-client[${PYTHON_USEDEP}]
- dev-python/pycountry[${PYTHON_USEDEP}]
- >=dev-python/pycryptodome-3.4.3[${PYTHON_USEDEP}]
- >dev-python/PySocks-1.5.7[${PYTHON_USEDEP}]
- >=dev-python/urllib3-1.26.0[${PYTHON_USEDEP}]
- >=dev-python/versioningit-2.0.0[${PYTHON_USEDEP}]
- ')
-"
-RDEPEND="
- ${DEPEND}
- media-video/ffmpeg
-"
-BDEPEND="
- $(python_gen_cond_dep '
- >=dev-python/versioningit-2.0.0[${PYTHON_USEDEP}]
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- >=dev-python/freezegun-1.0.0[${PYTHON_USEDEP}]
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/requests-mock[${PYTHON_USEDEP}]
- )
- ')
-"
-
-distutils_enable_tests pytest