summaryrefslogtreecommitdiff
path: root/net-misc/streamlink/streamlink-4.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-20 02:37:51 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-20 02:37:51 +0100
commitf090ac33320e52dd549b818be0c345a3bb870ae0 (patch)
tree2a93d78a55e094fd70aba050c185671713ca63e2 /net-misc/streamlink/streamlink-4.3.0.ebuild
parent343082998723d09c7b354eb21ff4793c6d4fda3e (diff)
gentoo auto-resync : 20:08:2022 - 02:37:51
Diffstat (limited to 'net-misc/streamlink/streamlink-4.3.0.ebuild')
-rw-r--r--net-misc/streamlink/streamlink-4.3.0.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/net-misc/streamlink/streamlink-4.3.0.ebuild b/net-misc/streamlink/streamlink-4.3.0.ebuild
new file mode 100644
index 000000000000..26cf80694fbd
--- /dev/null
+++ b/net-misc/streamlink/streamlink-4.3.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/streamlink/${PN}.git"
+ inherit git-r3
+fi
+
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE='xml(+),threads(+)'
+inherit distutils-r1
+
+DESCRIPTION="CLI for extracting streams from websites to a video player of your choice"
+HOMEPAGE="https://streamlink.github.io/"
+
+if [[ ${PV} != 9999* ]]; then
+ SRC_URI="https://github.com/streamlink/${PN}/releases/download/${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD-2 Apache-2.0"
+SLOT="0"
+
+DEPEND="
+ $(python_gen_cond_dep '
+ >dev-python/requests-2.21.0[${PYTHON_USEDEP}]
+ dev-python/isodate[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.6.4[${PYTHON_USEDEP}]
+ dev-python/websocket-client[${PYTHON_USEDEP}]
+ dev-python/pycountry[${PYTHON_USEDEP}]
+ >=dev-python/pycryptodome-3.4.3[${PYTHON_USEDEP}]
+ >dev-python/PySocks-1.5.7[${PYTHON_USEDEP}]
+ >=dev-python/versioningit-2.0.0[${PYTHON_USEDEP}]
+ ')
+"
+RDEPEND="${DEPEND}
+ media-video/ffmpeg
+"
+BDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/versioningit-2.0.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ >=dev-python/freezegun-1.0.0[${PYTHON_USEDEP}]
+ )
+ ')"
+
+distutils_enable_tests pytest