summaryrefslogtreecommitdiff
path: root/net-misc/streamlink/streamlink-2.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-24 02:11:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-24 02:11:45 +0100
commitb49088575eb777ced2551f484da86317332d6087 (patch)
treebf9a151cf2d61956340d555659ffc098ee1da466 /net-misc/streamlink/streamlink-2.0.0.ebuild
parent514d1bbe260df2521fe60f1a3ec87cfcfde1a829 (diff)
gentoo resync : 24.07.2021
Diffstat (limited to 'net-misc/streamlink/streamlink-2.0.0.ebuild')
-rw-r--r--net-misc/streamlink/streamlink-2.0.0.ebuild20
1 files changed, 10 insertions, 10 deletions
diff --git a/net-misc/streamlink/streamlink-2.0.0.ebuild b/net-misc/streamlink/streamlink-2.0.0.ebuild
index 4c7dab37c195..92c0803d4cf5 100644
--- a/net-misc/streamlink/streamlink-2.0.0.ebuild
+++ b/net-misc/streamlink/streamlink-2.0.0.ebuild
@@ -8,7 +8,7 @@ if [[ ${PV} = 9999* ]]; then
GIT_ECLASS="git-r3"
fi
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..9} )
PYTHON_REQ_USE='xml(+),threads(+)'
DISTUTILS_SINGLE_IMPL=1
inherit distutils-r1 ${GIT_ECLASS}
@@ -29,11 +29,11 @@ RESTRICT="!test? ( test )"
DEPEND="
$(python_gen_cond_dep '
- >dev-python/requests-2.21.0[${PYTHON_MULTI_USEDEP}]
- dev-python/isodate[${PYTHON_MULTI_USEDEP}]
- dev-python/websocket-client[${PYTHON_MULTI_USEDEP}]
- dev-python/pycountry[${PYTHON_MULTI_USEDEP}]
- >=dev-python/pycryptodome-3.4.3[${PYTHON_MULTI_USEDEP}]
+ >dev-python/requests-2.21.0[${PYTHON_USEDEP}]
+ dev-python/isodate[${PYTHON_USEDEP}]
+ dev-python/websocket-client[${PYTHON_USEDEP}]
+ dev-python/pycountry[${PYTHON_USEDEP}]
+ >=dev-python/pycryptodome-3.4.3[${PYTHON_USEDEP}]
')
"
RDEPEND="${DEPEND}
@@ -43,10 +43,10 @@ RDEPEND="${DEPEND}
BDEPEND="
$(python_gen_cond_dep '
test? (
- dev-python/mock[${PYTHON_MULTI_USEDEP}]
- dev-python/requests-mock[${PYTHON_MULTI_USEDEP}]
- dev-python/pytest[${PYTHON_MULTI_USEDEP}]
- >=dev-python/freezegun-1.0.0[${PYTHON_MULTI_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ >=dev-python/freezegun-1.0.0[${PYTHON_USEDEP}]
)
')"