summaryrefslogtreecommitdiff
path: root/net-misc/spread/spread-4.3.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-misc/spread/spread-4.3.0-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-misc/spread/spread-4.3.0-r1.ebuild')
-rw-r--r--net-misc/spread/spread-4.3.0-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-misc/spread/spread-4.3.0-r1.ebuild b/net-misc/spread/spread-4.3.0-r1.ebuild
new file mode 100644
index 000000000000..06bbce63e1c6
--- /dev/null
+++ b/net-misc/spread/spread-4.3.0-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+inherit user
+
+MY_PN="spread-src"
+
+DESCRIPTION="Distributed network messaging system"
+HOMEPAGE="http://www.spread.org"
+SRC_URI="mirror://gentoo/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="Spread-1.0 GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+pkg_setup() {
+ enewuser spread
+ enewgroup spread
+}
+
+src_prepare() {
+ default
+
+ # don't strip binaries
+ sed -i -e 's/0755 -s/0755/g' daemon/Makefile.in examples/Makefile.in
+}
+
+src_install() {
+ emake DESTDIR="${D}" docdir="/usr/share/doc/${PF}" install
+ newinitd "${FILESDIR}"/spread.init.d spread
+}