summaryrefslogtreecommitdiff
path: root/net-misc/spice-gtk/spice-gtk-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-02 19:14:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-02 19:14:55 +0100
commitb24bd25253fe093f722ab576d29fdc41d04cb1ee (patch)
tree0fcf2afd9f852c4d4c291cf8afaa2c244d598105 /net-misc/spice-gtk/spice-gtk-9999.ebuild
parent121ed4eec41fbf03e1998d09eede1bf449da63b9 (diff)
gentoo resync : 02.08.2019
Diffstat (limited to 'net-misc/spice-gtk/spice-gtk-9999.ebuild')
-rw-r--r--net-misc/spice-gtk/spice-gtk-9999.ebuild69
1 files changed, 32 insertions, 37 deletions
diff --git a/net-misc/spice-gtk/spice-gtk-9999.ebuild b/net-misc/spice-gtk/spice-gtk-9999.ebuild
index 37f1d9d190d6..c4e0bd6c740b 100644
--- a/net-misc/spice-gtk/spice-gtk-9999.ebuild
+++ b/net-misc/spice-gtk/spice-gtk-9999.ebuild
@@ -1,13 +1,14 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
GCONF_DEBUG="no"
WANT_AUTOMAKE="1.12"
VALA_MIN_API_VERSION="0.14"
VALA_USE_DEPEND="vapigen"
-inherit autotools eutils git-r3 readme.gentoo-r1 vala xdg-utils
+inherit autotools desktop eutils git-r3 readme.gentoo-r1 vala xdg-utils
DESCRIPTION="Set of GObject and Gtk objects for connecting to Spice servers and a client GUI"
HOMEPAGE="https://www.spice-space.org https://cgit.freedesktop.org/spice/spice-gtk/"
@@ -16,43 +17,34 @@ LICENSE="LGPL-2.1"
SLOT="0"
EGIT_REPO_URI="https://anongit.freedesktop.org/git/spice/spice-gtk.git"
KEYWORDS=""
-IUSE="dbus gstaudio gstvideo +gtk3 +introspection lz4 mjpeg policykit pulseaudio sasl smartcard static-libs usbredir vala webdav libressl"
-
-REQUIRED_USE="?? ( pulseaudio gstaudio )"
+IUSE="+gtk3 +introspection lz4 mjpeg policykit pulseaudio sasl smartcard static-libs usbredir vala webdav libressl"
# TODO:
# * check if sys-freebsd/freebsd-lib (from virtual/acl) provides acl/libacl.h
# * use external pnp.ids as soon as that means not pulling in gnome-desktop
RDEPEND="
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
- pulseaudio? ( media-sound/pulseaudio[glib] )
- gstvideo? (
- media-libs/gstreamer:1.0
- media-libs/gst-plugins-base:1.0
- media-libs/gst-plugins-good:1.0
- )
- gstaudio? (
- media-libs/gstreamer:1.0
- media-libs/gst-plugins-base:1.0
- media-libs/gst-plugins-good:1.0
- )
- >=x11-libs/pixman-0.17.7
- media-libs/opus
- gtk3? ( x11-libs/gtk+:3[introspection?] )
>=dev-libs/glib-2.46:2
- >=x11-libs/cairo-1.2
- virtual/jpeg:0=
+ dev-libs/json-glib:0=
+ media-libs/gst-plugins-base:1.0
+ media-libs/gst-plugins-good:1.0
+ media-libs/gstreamer:1.0
+ media-libs/opus
sys-libs/zlib
+ virtual/jpeg:0=
+ >=x11-libs/cairo-1.2
+ >=x11-libs/pixman-0.17.7
+ gtk3? ( x11-libs/gtk+:3[introspection?] )
introspection? ( dev-libs/gobject-introspection )
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
lz4? ( app-arch/lz4 )
+ pulseaudio? ( media-sound/pulseaudio[glib] )
sasl? ( dev-libs/cyrus-sasl )
smartcard? ( app-emulation/qemu[smartcard] )
usbredir? (
sys-apps/hwids
>=sys-apps/usbredir-0.4.2
virtual/libusb:1
- virtual/libgudev:=
policykit? (
sys-apps/acl
>=sys-auth/polkit-0.110-r1
@@ -62,6 +54,15 @@ RDEPEND="
net-libs/phodav:2.0
>=net-libs/libsoup-2.49.91 )
"
+# TODO: spice-gtk has an automagic dependency on x11-libs/libva without a
+# configure knob. The package is relatively lightweight so we just depend
+# on it unconditionally for now. It would be cleaner to transform this into
+# a USE="vaapi" conditional and patch the buildsystem...
+RDEPEND="${RDEPEND}
+ amd64? ( x11-libs/libva:= )
+ arm64? ( x11-libs/libva:= )
+ x86? ( x11-libs/libva:= )
+"
DEPEND="${RDEPEND}
~app-emulation/spice-protocol-9999
dev-perl/Text-CSV
@@ -76,7 +77,6 @@ DEPEND="${RDEPEND}
src_prepare() {
# bug 558558
export GIT_CEILING_DIRECTORIES="${WORKDIR}"
- echo GIT_CEILING_DIRECTORIES=${GIT_CEILING_DIRECTORIES}
default
@@ -96,22 +96,19 @@ src_configure() {
local myconf
myconf="
- $(use_enable static-libs static)
+ $(use_with gtk3 gtk 3.0)
$(use_enable introspection)
+ $(use_enable mjpeg builtin-mjpeg)
+ $(use_enable policykit polkit)
+ $(use_enable pulseaudio pulse)
$(use_with sasl)
$(use_enable smartcard)
+ $(use_enable static-libs static)
$(use_enable usbredir)
- $(use_with usbredir usb-ids-path /usr/share/misc/usb.ids)
$(use_with usbredir usb-acl-helper-dir /usr/libexec)
- $(use_with gtk3 gtk 3.0)
- $(use_enable policykit polkit)
- $(use_enable pulseaudio pulse)
- $(use_enable gstaudio)
- $(use_enable gstvideo)
- $(use_enable mjpeg builtin-mjpeg)
+ $(use_with usbredir usb-ids-path /usr/share/misc/usb.ids)
$(use_enable vala)
$(use_enable webdav)
- $(use_enable dbus)
--disable-celt051
--disable-gtk-doc
--disable-maintainer-mode
@@ -133,10 +130,8 @@ src_compile() {
src_install() {
default
- dodoc AUTHORS NEWS README
-
# Remove .la files if they're not needed
- use static-libs || prune_libtool_files
+ use static-libs || find "${D}" -name '*.la' -delete || die
make_desktop_entry spicy Spicy "utilities-terminal" "Network;RemoteAccess;"
readme.gentoo_create_doc