summaryrefslogtreecommitdiff
path: root/net-misc/spice-gtk/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-11-03 06:47:15 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-11-03 06:47:15 +0000
commitfc2f1018fc323ef2c6572734a9b130427cba76a6 (patch)
treef834bdc9a67923ce75297c09d00d1e7b90791d26 /net-misc/spice-gtk/files
parent162945d2a91899b637bbb9e163b406350de12906 (diff)
gentoo resync : 03.11.2021
Diffstat (limited to 'net-misc/spice-gtk/files')
-rw-r--r--net-misc/spice-gtk/files/spice-gtk-0.39-fix-finding-pyparsing.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/net-misc/spice-gtk/files/spice-gtk-0.39-fix-finding-pyparsing.patch b/net-misc/spice-gtk/files/spice-gtk-0.39-fix-finding-pyparsing.patch
new file mode 100644
index 000000000000..9a3cdd090063
--- /dev/null
+++ b/net-misc/spice-gtk/files/spice-gtk-0.39-fix-finding-pyparsing.patch
@@ -0,0 +1,13 @@
+https://gitlab.freedesktop.org/spice/spice-common/-/issues/5
+https://bugs.gentoo.org/820074
+--- a/subprojects/spice-common/meson.build
++++ b/subprojects/spice-common/meson.build
+@@ -132,7 +132,7 @@ if spice_common_generate_client_code or spice_common_generate_server_code
+ if get_option('python-checks')
+ foreach module : ['six', 'pyparsing']
+ message('Checking for python module @0@'.format(module))
+- cmd = run_command(python, '-m', module)
++ cmd = run_command(python, '-c', 'import @0@'.format(module))
+ if cmd.returncode() != 0
+ error('Python module @0@ not found'.format(module))
+ endif