summaryrefslogtreecommitdiff
path: root/net-misc/socket/socket-1.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-misc/socket/socket-1.5.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-misc/socket/socket-1.5.ebuild')
-rw-r--r--net-misc/socket/socket-1.5.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-misc/socket/socket-1.5.ebuild b/net-misc/socket/socket-1.5.ebuild
new file mode 100644
index 000000000000..a08430d13f1f
--- /dev/null
+++ b/net-misc/socket/socket-1.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit base toolchain-funcs
+
+DESCRIPTION="A shell-level interface to TCP sockets"
+HOMEPAGE="http://www.jnickelsen.de/socket/"
+SRC_URI="http://www.jnickelsen.de/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+
+IUSE="examples"
+
+PATCHES=( "${FILESDIR}/${P}-makefile.patch" )
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin socket
+ doman socket.1
+ dodoc BLURB CHANGES README
+ if use examples; then
+ docinto examples
+ dodoc scripts/*
+ fi
+}