summaryrefslogtreecommitdiff
path: root/net-misc/socat/socat-1.7.4.4-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-06 09:22:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-06 09:22:07 +0100
commit9b81b8a93760fc1c7d79561adbd7a62c82f334db (patch)
tree91cf0d90ea0a8fff253b43d0648c2d48649884e4 /net-misc/socat/socat-1.7.4.4-r1.ebuild
parent681aad60df032a891dbbfc38f3ea4b404d6a8579 (diff)
gentoo auto-resync : 06:08:2023 - 09:22:07
Diffstat (limited to 'net-misc/socat/socat-1.7.4.4-r1.ebuild')
-rw-r--r--net-misc/socat/socat-1.7.4.4-r1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/net-misc/socat/socat-1.7.4.4-r1.ebuild b/net-misc/socat/socat-1.7.4.4-r1.ebuild
new file mode 100644
index 000000000000..26ff914b02af
--- /dev/null
+++ b/net-misc/socat/socat-1.7.4.4-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic toolchain-funcs
+
+MY_P=${P/_beta/-b}
+DESCRIPTION="Multipurpose relay (SOcket CAT)"
+HOMEPAGE="http://www.dest-unreach.org/socat/ https://repo.or.cz/socat.git"
+SRC_URI="http://www.dest-unreach.org/socat/download/${MY_P}.tar.bz2"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="ipv6 readline ssl tcpd"
+
+DEPEND="ssl? ( dev-libs/openssl:0= )
+ readline? ( sys-libs/readline:= )
+ tcpd? ( sys-apps/tcp-wrappers )"
+RDEPEND="${DEPEND}"
+
+# Tests are a large bash script
+# Hard to disable individual tests needing network or privileges
+# in 1.7.4.2: FAILED: 59 329
+RESTRICT="test"
+
+DOCS=( BUGREPORTS CHANGES DEVELOPMENT EXAMPLES FAQ FILES PORTING README SECURITY )
+
+src_configure() {
+ # bug #293324
+ filter-flags '-Wno-error*'
+
+ tc-export AR
+
+ econf \
+ $(use_enable ssl openssl) \
+ $(use_enable readline) \
+ $(use_enable ipv6 ip6) \
+ $(use_enable tcpd libwrap)
+}
+
+src_install() {
+ default
+
+ docinto html
+ dodoc doc/*.html doc/*.css
+}