summaryrefslogtreecommitdiff
path: root/net-misc/smbc/smbc-1.2.2-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-08 09:04:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-08 09:04:53 +0100
commit73c318acdaf6f8309d68bd266051e6dd1f1bd787 (patch)
tree2878053f3e7faed19a1f82c733d3bd29df69991e /net-misc/smbc/smbc-1.2.2-r3.ebuild
parent2018227e9344edb9da15fc6a4a8298086cc2aa77 (diff)
gentoo resync : 08.06.2019
Diffstat (limited to 'net-misc/smbc/smbc-1.2.2-r3.ebuild')
-rw-r--r--net-misc/smbc/smbc-1.2.2-r3.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-misc/smbc/smbc-1.2.2-r3.ebuild b/net-misc/smbc/smbc-1.2.2-r3.ebuild
new file mode 100644
index 000000000000..87ebd6eea0a6
--- /dev/null
+++ b/net-misc/smbc/smbc-1.2.2-r3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Text mode (ncurses) SMB network commander. Features: resume and UTF-8"
+HOMEPAGE="https://sourceforge.net/projects/smbc/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE="nls debug"
+
+DEPEND="dev-libs/popt
+ net-fs/samba
+ sys-libs/ncurses
+ nls? ( sys-devel/gettext )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ mv configure.{in,ac} || die
+ eapply "${FILESDIR}"/${P}-cflags.patch
+ eapply "${FILESDIR}"/${P}-size_t.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_with debug)
+}
+
+src_install() {
+ default
+ mkdir -p "${D}/usr/share/doc"
+ mv -v "${D}/usr/share/"{${PN},doc/${PF}} || die
+}