summaryrefslogtreecommitdiff
path: root/net-misc/shmux/shmux-1.0.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-24 20:54:05 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-24 20:54:05 +0100
commitfc879856a16ea66528a11a00cf6ee19891f3d186 (patch)
tree01ac0b4134970567587e7176ffc531a404898186 /net-misc/shmux/shmux-1.0.3.ebuild
parentf73bef95b39f4fbc8f0278c26ad1534e5eec322f (diff)
gentoo auto-resync : 24:07:2022 - 20:54:05
Diffstat (limited to 'net-misc/shmux/shmux-1.0.3.ebuild')
-rw-r--r--net-misc/shmux/shmux-1.0.3.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/net-misc/shmux/shmux-1.0.3.ebuild b/net-misc/shmux/shmux-1.0.3.ebuild
new file mode 100644
index 000000000000..07fa2c590a43
--- /dev/null
+++ b/net-misc/shmux/shmux-1.0.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="run the same command across many hosts in parallel"
+HOMEPAGE="http://web.taranis.org/shmux/"
+SRC_URI="http://web.taranis.org/${PN}/dist/${P}.tgz"
+
+LICENSE="shmux"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~x86"
+IUSE="pcre"
+RESTRICT="test"
+
+RDEPEND="
+ pcre? ( dev-libs/libpcre )
+ sys-libs/ncurses:0=
+"
+
+DEPEND="
+ ${RDEPEND}
+ virtual/awk"
+
+PATCHES=( "${FILESDIR}"/${P}-tinfo.patch )
+
+DOCS=( CHANGES )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_with pcre)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ einstalldocs
+}