summaryrefslogtreecommitdiff
path: root/net-misc/secpanel/secpanel-0.6.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-misc/secpanel/secpanel-0.6.1-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-misc/secpanel/secpanel-0.6.1-r1.ebuild')
-rw-r--r--net-misc/secpanel/secpanel-0.6.1-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/net-misc/secpanel/secpanel-0.6.1-r1.ebuild b/net-misc/secpanel/secpanel-0.6.1-r1.ebuild
new file mode 100644
index 000000000000..e504942af286
--- /dev/null
+++ b/net-misc/secpanel/secpanel-0.6.1-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=2
+
+DESCRIPTION="Graphical frontend for managing and running SSH and SCP connections"
+HOMEPAGE="http://themediahost.de/secpanel/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 sparc x86"
+IUSE="gif"
+
+DEPEND="!gif? ( virtual/imagemagick-tools )"
+
+RDEPEND="virtual/ssh dev-lang/tk"
+
+S=${WORKDIR}/usr/local
+
+src_prepare() {
+ # install arch indep stuff in /usr/share instead of /usr/lib*
+ sed -i -e '/set libdir/s:../lib:../share:' bin/secpanel || die
+
+ # fix the version
+ sed -i -e "/set spversion/s:0.6.0:${PV}:" bin/secpanel || die
+
+ # optionally remove gifs...
+ if ! use gif; then
+ einfo "Setting secpanel to use PPM images"
+ sed -i -e 's/\.gif/\.ppm/g' bin/secpanel || die
+
+ einfo "Converting all GIF images to PPM format..."
+ for i in $(find lib/secpanel/images -name "*.gif") ; do
+ einfo "convert ${i} => ${i//.gif/.ppm}"
+ convert "${i}" "ppm:${i//.gif/.ppm}" || die
+ rm -v "${i}" || die
+ done
+ fi
+}
+
+src_install() {
+ dobin bin/secpanel || die
+
+ insinto /usr/share/secpanel
+ doins -r lib/secpanel/{*.{tcl,config,profile,wait,txt,sh},images,spdistkey} || die
+}