summaryrefslogtreecommitdiff
path: root/net-misc/s3cmd/s3cmd-2.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
commit46eedbedafdb0040c37884982d4c775ce277fb7b (patch)
treedb33a91259730be84999e13a8d8168c799f50ac0 /net-misc/s3cmd/s3cmd-2.2.0.ebuild
parente23a08d0c97a0cc415aaa165da840b056f93c997 (diff)
gentoo resync : 20.10.2021
Diffstat (limited to 'net-misc/s3cmd/s3cmd-2.2.0.ebuild')
-rw-r--r--net-misc/s3cmd/s3cmd-2.2.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-misc/s3cmd/s3cmd-2.2.0.ebuild b/net-misc/s3cmd/s3cmd-2.2.0.ebuild
new file mode 100644
index 000000000000..e69e258d6648
--- /dev/null
+++ b/net-misc/s3cmd/s3cmd-2.2.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_7 python3_8 python3_9 )
+PYTHON_REQ_USE="xml"
+
+inherit distutils-r1
+
+DESCRIPTION="Command line client for Amazon S3"
+HOMEPAGE="https://s3tools.org/s3cmd"
+SRC_URI="mirror://sourceforge/s3tools/${P/_/-}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~x86 ~amd64-linux ~x64-macos"
+
+RDEPEND="
+ || (
+ dev-python/python-magic[${PYTHON_USEDEP}]
+ sys-apps/file[python,${PYTHON_USEDEP}]
+ )
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ "
+
+S="${WORKDIR}/${P/_/-}"
+
+PATCHES=( )
+
+src_install() {
+ distutils-r1_src_install
+ rm -rf "${ED}/usr/share/doc/packages"
+}