summaryrefslogtreecommitdiff
path: root/net-misc/s3cmd/s3cmd-1.6.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-misc/s3cmd/s3cmd-1.6.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-misc/s3cmd/s3cmd-1.6.1.ebuild')
-rw-r--r--net-misc/s3cmd/s3cmd-1.6.1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/net-misc/s3cmd/s3cmd-1.6.1.ebuild b/net-misc/s3cmd/s3cmd-1.6.1.ebuild
new file mode 100644
index 000000000000..acafa8124728
--- /dev/null
+++ b/net-misc/s3cmd/s3cmd-1.6.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="xml"
+
+inherit distutils-r1
+
+DESCRIPTION="Command line client for Amazon S3"
+HOMEPAGE="http://s3tools.org/s3cmd"
+SRC_URI="mirror://sourceforge/s3tools/${P/_/-}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="amd64 x86 ~x64-macos"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/python-magic[${PYTHON_USEDEP}]"
+
+S="$WORKDIR/${P/_/-}"