summaryrefslogtreecommitdiff
path: root/net-misc/rsync/rsync-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-16 08:29:51 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-16 08:29:51 +0100
commit930cc7d721b1ea68468608da3ce2b4e891926834 (patch)
tree70cca50a8531fb107466c80606c7c36376e0cb69 /net-misc/rsync/rsync-9999.ebuild
parent7896e968620f545121daeea31881814ccc8d4f47 (diff)
gentoo auto-resync : 16:08:2022 - 08:29:51
Diffstat (limited to 'net-misc/rsync/rsync-9999.ebuild')
-rw-r--r--net-misc/rsync/rsync-9999.ebuild15
1 files changed, 8 insertions, 7 deletions
diff --git a/net-misc/rsync/rsync-9999.ebuild b/net-misc/rsync/rsync-9999.ebuild
index ab9d689fb713..5e5ba3f5fabb 100644
--- a/net-misc/rsync/rsync-9999.ebuild
+++ b/net-misc/rsync/rsync-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=8
PYTHON_COMPAT=( python3_{8..10} )
-inherit flag-o-matic prefix python-single-r1 systemd
+inherit prefix python-single-r1 systemd
DESCRIPTION="File transfer program to keep remote files into sync"
HOMEPAGE="https://rsync.samba.org/"
@@ -34,18 +34,19 @@ SLOT="0"
IUSE="acl examples iconv lz4 ssl stunnel system-zlib xattr xxhash zstd"
REQUIRED_USE+=" examples? ( ${PYTHON_REQUIRED_USE} )"
-RDEPEND="acl? ( virtual/acl )
+RDEPEND="
+ >=dev-libs/popt-1.5
+ acl? ( virtual/acl )
examples? (
${PYTHON_DEPS}
dev-lang/perl
)
- lz4? ( app-arch/lz4 )
- ssl? ( dev-libs/openssl:0= )
+ lz4? ( app-arch/lz4:= )
+ ssl? ( dev-libs/openssl:= )
system-zlib? ( sys-libs/zlib )
xattr? ( kernel_linux? ( sys-apps/attr ) )
- xxhash? ( dev-libs/xxhash )
- zstd? ( >=app-arch/zstd-1.4 )
- >=dev-libs/popt-1.5
+ xxhash? ( >=dev-libs/xxhash-0.8 )
+ zstd? ( >=app-arch/zstd-1.4:= )
iconv? ( virtual/libiconv )"
DEPEND="${RDEPEND}"
BDEPEND="examples? ( ${PYTHON_DEPS} )"