summaryrefslogtreecommitdiff
path: root/net-misc/rsync/rsync-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-08 04:37:19 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-08 04:37:19 +0100
commit8bba0fff0bc9709d45aeb68336998e11d118ab05 (patch)
tree028aab3e3fe08bcbb0cbbd5dd1696ef5e68823d7 /net-misc/rsync/rsync-9999.ebuild
parentd6afc0279cc61e309c2696d5bd758451f97b6a5b (diff)
gentoo auto-resync : 08:09:2022 - 04:37:19
Diffstat (limited to 'net-misc/rsync/rsync-9999.ebuild')
-rw-r--r--net-misc/rsync/rsync-9999.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/net-misc/rsync/rsync-9999.ebuild b/net-misc/rsync/rsync-9999.ebuild
index 1abfebf444ed..804909ae11e6 100644
--- a/net-misc/rsync/rsync-9999.ebuild
+++ b/net-misc/rsync/rsync-9999.ebuild
@@ -3,6 +3,8 @@
EAPI=8
+# Uncomment when introducing a patch which touches configure
+#RSYNC_NEEDS_AUTOCONF=1
PYTHON_COMPAT=( python3_{8..10} )
inherit prefix python-single-r1 systemd
@@ -17,6 +19,10 @@ else
VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/waynedavison.asc
inherit verify-sig
+ if [[ -n ${RSYNC_NEEDS_AUTOCONF} ]] ; then
+ inherit autotools
+ fi
+
if [[ ${PV} == *_pre* ]] ; then
SRC_DIR="src-previews"
else
@@ -71,7 +77,7 @@ pkg_setup() {
src_prepare() {
default
- if [[ ${PV} == *9999 ]] ; then
+ if [[ ${PV} == *9999 || -n ${RSYNC_NEEDS_AUTOCONF} ]] ; then
eaclocal -I m4
eautoconf -o configure.sh
eautoheader && touch config.h.in