summaryrefslogtreecommitdiff
path: root/net-misc/rsync/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
commitfeb0daf81d888e9160f9f94502de09b66f2a63fd (patch)
treeb6e5c40ce2abef3da27ed50a023153f475e0ddef /net-misc/rsync/files
parent9452a6e87b6c2c70513bc47a2470bf9f1168920e (diff)
gentoo resync : 21.06.2020
Diffstat (limited to 'net-misc/rsync/files')
-rw-r--r--net-misc/rsync/files/rsync-3.2.0-noexecstack.patch24
-rw-r--r--net-misc/rsync/files/rsync-3.2.0-simd_check.patch13
2 files changed, 37 insertions, 0 deletions
diff --git a/net-misc/rsync/files/rsync-3.2.0-noexecstack.patch b/net-misc/rsync/files/rsync-3.2.0-noexecstack.patch
new file mode 100644
index 000000000000..918346062e6a
--- /dev/null
+++ b/net-misc/rsync/files/rsync-3.2.0-noexecstack.patch
@@ -0,0 +1,24 @@
+From 75901616c5f38a9ff6ba736c8281933e8ce64b8b Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Holger=20Hoffst=C3=A4tte?= <holger@applied-asynchrony.com>
+Date: Sat, 20 Jun 2020 16:54:11 +0200
+Subject: [PATCH] Pass --noexecstack to assembler.
+
+This prevents Linux from rightfully complaining about an executable
+stack segment, which is widely considered a security hazard.
+---
+ Makefile.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile.in b/Makefile.in
+index 31ddc43b..60aff920 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -135,7 +135,7 @@ simd-checksum-x86_64.o: simd-checksum-x86_64.cpp
+ $(CXX) $(CXXFLAGS) $(CPPFLAGS) -c -o $@ $(srcdir)/simd-checksum-x86_64.cpp
+
+ lib/md5-asm-x86_64.o: lib/md5-asm-x86_64.s
+- $(CC) -c -o $@ $(srcdir)/lib/md5-asm-x86_64.s
++ $(CC) -Wa,--noexecstack -c -o $@ $(srcdir)/lib/md5-asm-x86_64.s
+
+ tls$(EXEEXT): $(TLS_OBJ)
+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(TLS_OBJ) $(LIBS)
diff --git a/net-misc/rsync/files/rsync-3.2.0-simd_check.patch b/net-misc/rsync/files/rsync-3.2.0-simd_check.patch
new file mode 100644
index 000000000000..255f2792dc07
--- /dev/null
+++ b/net-misc/rsync/files/rsync-3.2.0-simd_check.patch
@@ -0,0 +1,13 @@
+https://github.com/WayneD/rsync/pull/24
+
+--- rsync-3.2.0/configure.ac 2020-06-19 23:11:01.000000000 +0200
++++ rsync-3.2.0/configure.ac 2020-06-19 23:11:01.000000000 +0200
+@@ -207,7 +207,7 @@
+ if test x"$CXX" != x""; then
+ CXX_VERSION=`$CXX --version 2>/dev/null | head -n 1`
+ case "$CXX_VERSION" in
+- g++*)
++ *g++*)
+ CXX_VERSION=`$CXX -dumpversion | sed 's/\..*//g'`
+ if test "$CXX_VERSION" -ge "5"; then
+ CXX_OK=yes