summaryrefslogtreecommitdiff
path: root/net-misc/rdate/rdate-1.4-r4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-misc/rdate/rdate-1.4-r4.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-misc/rdate/rdate-1.4-r4.ebuild')
-rw-r--r--net-misc/rdate/rdate-1.4-r4.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-misc/rdate/rdate-1.4-r4.ebuild b/net-misc/rdate/rdate-1.4-r4.ebuild
new file mode 100644
index 000000000000..3a0fc636df3e
--- /dev/null
+++ b/net-misc/rdate/rdate-1.4-r4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit flag-o-matic
+
+DESCRIPTION="use TCP or UDP to retrieve the current time of another machine"
+HOMEPAGE="http://www.apps.ietf.org/rfc/rfc868.html"
+SRC_URI="ftp://people.redhat.com/sopwith/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86"
+IUSE="ipv6"
+
+DEPEND=""
+
+src_prepare() {
+ sed -i \
+ -e '/^CFLAGS=/d' \
+ -e '/^rdate: /,+1d' \
+ -e '/\tinstall/s:\([^ ]\+\)$:$(DESTDIR)&:' \
+ Makefile || die "Sed failed!"
+}
+
+src_compile() {
+ use ipv6 && append-cppflags "-DINET6"
+ tc-export CC
+ emake
+}
+
+src_install(){
+ emake DESTDIR="${D}" install
+ newinitd "${FILESDIR}"/rdate-initd-1.4-r3 rdate
+ newconfd "${FILESDIR}"/rdate-confd rdate
+}