summaryrefslogtreecommitdiff
path: root/net-misc/rclone/rclone-1.62.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-22 06:41:43 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-22 06:41:43 +0000
commitaaeed2da8906f11cba80355688015d74b01cc604 (patch)
tree5d714c0600fd3f185c0ddb96eef8dd41a5f3ec5e /net-misc/rclone/rclone-1.62.2.ebuild
parent23b767af73549eeb4dd3069e09d0f2fcb88669a8 (diff)
gentoo auto-resync : 22:03:2023 - 06:41:43
Diffstat (limited to 'net-misc/rclone/rclone-1.62.2.ebuild')
-rw-r--r--net-misc/rclone/rclone-1.62.2.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/net-misc/rclone/rclone-1.62.2.ebuild b/net-misc/rclone/rclone-1.62.2.ebuild
deleted file mode 100644
index 649ec2384a36..000000000000
--- a/net-misc/rclone/rclone-1.62.2.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-inherit bash-completion-r1 go-module
-
-KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
-SRC_URI="
- https://github.com/rclone/rclone/archive/v${PV}.tar.gz -> ${P}.tar.gz
- https://dev.gentoo.org/~slashbeast/distfiles/${PN}/${P}-deps.tar.xz
-"
-
-DESCRIPTION="A program to sync files to and from various cloud storage providers"
-HOMEPAGE="https://rclone.org/"
-
-LICENSE="Apache-2.0 BSD BSD-2 ISC MIT MPL-2.0"
-SLOT="0"
-IUSE=""
-
-src_compile() {
- go build -mod=readonly . || die "compile failed"
-}
-
-src_test() {
- # Setting CI skips unreliable tests, see fstest/testy/testy.go
- # TestAddPlugin and TestRemovePlugin fail
- RCLONE_CONFIG="/notfound" CI="true" go test -mod=readonly -v -run "!Test.*Plugin" ./... || die "test failed"
-}
-
-src_install() {
- dobin ${PN}
- doman ${PN}.1
- dodoc README.md
-
- ./rclone genautocomplete bash ${PN}.bash || die
- newbashcomp ${PN}.bash ${PN}
-
- ./rclone genautocomplete zsh ${PN}.zsh || die
- insinto /usr/share/zsh/site-functions
- newins ${PN}.zsh _${PN}
-}