summaryrefslogtreecommitdiff
path: root/net-misc/rclone/rclone-1.59.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-20 23:24:40 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-20 23:24:40 +0100
commit3f9a144d38a57497a44a583d11a6e3dfbe8319d5 (patch)
treecb0e6beb4b79e1f7ccd95c75c9f434fdad11a071 /net-misc/rclone/rclone-1.59.2.ebuild
parent800c4c398cad9dd837da33062e71ccc84114fe05 (diff)
gentoo auto-resync : 20:09:2022 - 23:24:40
Diffstat (limited to 'net-misc/rclone/rclone-1.59.2.ebuild')
-rw-r--r--net-misc/rclone/rclone-1.59.2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-misc/rclone/rclone-1.59.2.ebuild b/net-misc/rclone/rclone-1.59.2.ebuild
new file mode 100644
index 000000000000..7c77180a06c2
--- /dev/null
+++ b/net-misc/rclone/rclone-1.59.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit bash-completion-r1 go-module
+
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+SRC_URI="
+ https://github.com/rclone/rclone/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://dev.gentoo.org/~slashbeast/distfiles/${PN}/${P}-deps.tar.xz
+"
+
+DESCRIPTION="A program to sync files to and from various cloud storage providers"
+HOMEPAGE="https://rclone.org/"
+
+LICENSE="Apache-2.0 BSD BSD-2 ISC MIT MPL-2.0"
+SLOT="0"
+IUSE=""
+
+src_compile() {
+ go build -mod=readonly . || die "compile failed"
+}
+
+src_test() {
+ # Setting CI skips unreliable tests, see fstest/testy/testy.go
+ # TestAddPlugin and TestRemovePlugin fail
+ RCLONE_CONFIG="/notfound" CI="true" go test -mod=readonly -v -run "!Test.*Plugin" ./... || die "test failed"
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+ dodoc README.md
+
+ ./rclone genautocomplete bash ${PN}.bash || die
+ newbashcomp ${PN}.bash ${PN}
+
+ ./rclone genautocomplete zsh ${PN}.zsh || die
+ insinto /usr/share/zsh/site-functions
+ newins ${PN}.zsh _${PN}
+}