summaryrefslogtreecommitdiff
path: root/net-misc/rclone/rclone-1.39.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-23 04:19:44 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-23 04:19:44 +0000
commitc5283d322accc6097afec74eab24550829788bab (patch)
treeb99ce668128d82a026eaa31461643f9173f9b77b /net-misc/rclone/rclone-1.39.ebuild
parent5510d9d7d1c93c2ea71a2bd6f0666168808d5dd6 (diff)
gentoo resync : 23.03.2018
Diffstat (limited to 'net-misc/rclone/rclone-1.39.ebuild')
-rw-r--r--net-misc/rclone/rclone-1.39.ebuild17
1 files changed, 13 insertions, 4 deletions
diff --git a/net-misc/rclone/rclone-1.39.ebuild b/net-misc/rclone/rclone-1.39.ebuild
index ab1b0c69b3d5..2c530609ee7b 100644
--- a/net-misc/rclone/rclone-1.39.ebuild
+++ b/net-misc/rclone/rclone-1.39.ebuild
@@ -1,10 +1,8 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-
-inherit golang-build
-
+inherit golang-build bash-completion-r1
EGO_PN="github.com/ncw/${PN}"
if [[ ${PV} == *9999* ]]; then
@@ -21,9 +19,20 @@ HOMEPAGE="https://rclone.org/"
LICENSE="MIT"
SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
src_install() {
dobin ${PN}
doman src/${EGO_PN}/${PN}.1
dodoc src/${EGO_PN}/README.md
+
+ ./rclone genautocomplete bash ${PN}.bash || die
+ newbashcomp ${PN}.bash ${PN}
+
+ ./rclone genautocomplete zsh ${PN}.zsh || die
+ insinto /usr/share/zsh/site-functions
+ newins ${PN}.zsh _${PN}
}