summaryrefslogtreecommitdiff
path: root/net-misc/radvd/radvd-2.19-r5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-24 07:10:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-24 07:10:12 +0000
commita59ffccce3bf214fae9932cc42400eeeaec25c6c (patch)
tree62251d3d21f2b36c2fbc08a3343513934bc06a36 /net-misc/radvd/radvd-2.19-r5.ebuild
parente33383d972aad8129fd4c1ee2b87f529f6efa8e9 (diff)
gentoo auto-resync : 24:11:2022 - 07:10:12
Diffstat (limited to 'net-misc/radvd/radvd-2.19-r5.ebuild')
-rw-r--r--net-misc/radvd/radvd-2.19-r5.ebuild74
1 files changed, 74 insertions, 0 deletions
diff --git a/net-misc/radvd/radvd-2.19-r5.ebuild b/net-misc/radvd/radvd-2.19-r5.ebuild
new file mode 100644
index 000000000000..339fa3d60deb
--- /dev/null
+++ b/net-misc/radvd/radvd-2.19-r5.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools readme.gentoo-r1 systemd toolchain-funcs
+
+DESCRIPTION="Linux IPv6 Router Advertisement Daemon"
+HOMEPAGE="https://v6web.litech.org/radvd/"
+SRC_URI="https://v6web.litech.org/radvd/dist/${P}.tar.xz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="selinux test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="
+ sys-devel/bison
+ sys-devel/flex
+ test? ( dev-libs/check )
+"
+RDEPEND="
+ acct-group/radvd
+ acct-user/radvd
+ selinux? ( sec-policy/selinux-radvd )
+"
+
+DOCS=( CHANGES README TODO radvd.conf.example )
+
+PATCHES=(
+ "${FILESDIR}"/${P}-musl-include.patch
+ "${FILESDIR}"/${P}-clang16.patch
+)
+
+src_prepare() {
+ default
+
+ # Drop once clang16 patch is in a release
+ eautoreconf
+}
+
+src_configure() {
+ econf --with-pidfile=/run/radvd/radvd.pid \
+ --with-systemdsystemunitdir=no \
+ $(use_with test check)
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ default
+
+ docinto html
+ dodoc INTRO.html
+
+ newinitd "${FILESDIR}"/${PN}-2.15.init ${PN}
+ newconfd "${FILESDIR}"/${PN}.conf ${PN}
+
+ systemd_dounit "${FILESDIR}"/${PN}.service
+
+ readme.gentoo_create_doc
+}
+
+DISABLE_AUTOFORMATTING=1
+DOC_CONTENTS="Please create a configuration file ${ROOT}/etc/radvd.conf.
+See ${ROOT}/usr/share/doc/${PF} for an example.
+
+grsecurity users should allow a specific group to read /proc
+and add the radvd user to that group, otherwise radvd may
+segfault on startup."