summaryrefslogtreecommitdiff
path: root/net-misc/pyhoca-cli/pyhoca-cli-0.6.1.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /net-misc/pyhoca-cli/pyhoca-cli-0.6.1.2.ebuild
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'net-misc/pyhoca-cli/pyhoca-cli-0.6.1.2.ebuild')
-rw-r--r--net-misc/pyhoca-cli/pyhoca-cli-0.6.1.2.ebuild15
1 files changed, 10 insertions, 5 deletions
diff --git a/net-misc/pyhoca-cli/pyhoca-cli-0.6.1.2.ebuild b/net-misc/pyhoca-cli/pyhoca-cli-0.6.1.2.ebuild
index 3f2ee6193450..107198b5c85b 100644
--- a/net-misc/pyhoca-cli/pyhoca-cli-0.6.1.2.ebuild
+++ b/net-misc/pyhoca-cli/pyhoca-cli-0.6.1.2.ebuild
@@ -3,21 +3,26 @@
EAPI=7
-PYTHON_COMPAT=( python3_7 )
+PYTHON_COMPAT=( python3_{7..9} )
inherit distutils-r1
DESCRIPTION="X2Go command line client"
HOMEPAGE="http://www.x2go.org"
SRC_URI="http://code.x2go.org/releases/source/${PN}/${P}.tar.gz"
-LICENSE="AGPL-3"
+LICENSE="AGPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-DEPEND="dev-python/setproctitle[${PYTHON_USEDEP}]
+RDEPEND="
+ dev-python/setproctitle[${PYTHON_USEDEP}]
>=net-misc/python-x2go-0.6.1.1[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
+
+python_prepare_all() {
+ # we don't need setuptools at runtime
+ sed -i -e '/install_requires/d' setup.py || die
+ distutils-r1_python_prepare_all
+}
python_install() {
distutils-r1_python_install