summaryrefslogtreecommitdiff
path: root/net-misc/portspoof/portspoof-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-misc/portspoof/portspoof-9999.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-misc/portspoof/portspoof-9999.ebuild')
-rw-r--r--net-misc/portspoof/portspoof-9999.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-misc/portspoof/portspoof-9999.ebuild b/net-misc/portspoof/portspoof-9999.ebuild
new file mode 100644
index 000000000000..7dc45df92641
--- /dev/null
+++ b/net-misc/portspoof/portspoof-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+DESCRIPTION="return SYN+ACK for every port connection attempt"
+HOMEPAGE="http://portspoof.org/"
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3 autotools
+ EGIT_REPO_URI="https://github.com/drk1wi/${PN}.git"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/drk1wi/portspoof/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+src_prepare() {
+ if [[ ${PV} == "9999" ]] ; then
+ eautoreconf
+ fi
+ sed -i \
+ 's#/usr/local/bin/portspoof -D -c /usr/local/etc/portspoof.conf -s /usr/local/etc/portspoof_signatures#/usr/bin/portspoof -D -c /etc/portspoof.conf -s /etc/portspoof_signatures#'\
+ system_files/init.d/portspoof.sh
+}
+
+src_install() {
+ default_src_install
+ newsbin system_files/init.d/portspoof.sh portspoof-runner
+}