summaryrefslogtreecommitdiff
path: root/net-misc/portfwd/portfwd-0.29-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-19 00:32:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-19 00:32:54 +0000
commit434fbe89e81a1fe06d92676be72ab7f862cc3f53 (patch)
tree7ed0f70fded2af7cbc43e42097f4cd2cebd8c845 /net-misc/portfwd/portfwd-0.29-r2.ebuild
parentcd0d9000770337b445051f1852fe3971ceb7a6e2 (diff)
gentoo auto-resync : 19:03:2023 - 00:32:54
Diffstat (limited to 'net-misc/portfwd/portfwd-0.29-r2.ebuild')
-rw-r--r--net-misc/portfwd/portfwd-0.29-r2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-misc/portfwd/portfwd-0.29-r2.ebuild b/net-misc/portfwd/portfwd-0.29-r2.ebuild
new file mode 100644
index 000000000000..98f201afdb05
--- /dev/null
+++ b/net-misc/portfwd/portfwd-0.29-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools systemd
+
+DESCRIPTION="Port Forwarding Daemon"
+HOMEPAGE="http://portfwd.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ia64 ~ppc ~sparc x86"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.29-build-system.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ dodoc cfg/*
+
+ newinitd "${FILESDIR}"/${PN}.init ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+ systemd_dounit "${FILESDIR}"/${PN}.service
+}