summaryrefslogtreecommitdiff
path: root/net-misc/openrdap/openrdap-0.9.0_p20191017-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /net-misc/openrdap/openrdap-0.9.0_p20191017-r1.ebuild
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'net-misc/openrdap/openrdap-0.9.0_p20191017-r1.ebuild')
-rw-r--r--net-misc/openrdap/openrdap-0.9.0_p20191017-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-misc/openrdap/openrdap-0.9.0_p20191017-r1.ebuild b/net-misc/openrdap/openrdap-0.9.0_p20191017-r1.ebuild
new file mode 100644
index 000000000000..d7e9899224db
--- /dev/null
+++ b/net-misc/openrdap/openrdap-0.9.0_p20191017-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+EGIT_COMMIT="af93e7ef17b78dee3e346814731377d5ef7b89f3"
+go-module_set_globals
+
+DESCRIPTION="RDAP command line client"
+HOMEPAGE="
+ https://www.openrdap.org/
+ https://github.com/openrdap/rdap
+"
+SRC_URI="
+ https://github.com/openrdap/rdap/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz
+ https://dev.gentoo.org/~conikost/distfiles/${P}-deps.tar.gz
+"
+S="${WORKDIR}/${PN/open/}-${EGIT_COMMIT}"
+
+LICENSE="BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_compile() {
+ go build ./cmd/rdap || die
+}
+
+src_install() {
+ dobin rdap
+ einstalldocs
+}