summaryrefslogtreecommitdiff
path: root/net-misc/omnisync/omnisync-1.0_p20200130.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
commit29aabba0ea759c6a2864ff5631735b67ee38e5e0 (patch)
treeab466b4dfa7abecb401b2f8039d08af4689306bb /net-misc/omnisync/omnisync-1.0_p20200130.ebuild
parentd42200bec37eef2a7478d88988ff00addd0a9202 (diff)
gentoo resync : 05.02.2020
Diffstat (limited to 'net-misc/omnisync/omnisync-1.0_p20200130.ebuild')
-rw-r--r--net-misc/omnisync/omnisync-1.0_p20200130.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-misc/omnisync/omnisync-1.0_p20200130.ebuild b/net-misc/omnisync/omnisync-1.0_p20200130.ebuild
new file mode 100644
index 000000000000..c0a9f2f3dae6
--- /dev/null
+++ b/net-misc/omnisync/omnisync-1.0_p20200130.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake vcs-snapshot
+
+SNAPSHOT="c55215330b1e8a61af6d34d57d3d8236c8cc7d5b"
+
+DESCRIPTION="A driver for NTPd for people who are firewall-challenged"
+HOMEPAGE="https://www.vanheusden.com/time/omnisync"
+LICENSE="GPL-2"
+SRC_URI="https://gitlab.com/grknight/omnisync/-/archive/${SNAPSHOT}/omnisync-${SNAPSHOT}.tar.bz2 -> ${P}.tar.bz2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="net-libs/gnutls:= net-analyzer/net-snmp:="
+DEPEND="${RDEPEND}"
+DOCS=( readme.txt Changes )
+
+src_install() {
+ cmake_src_install
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+ einstalldocs
+}
+
+pkg_postinst() {
+ local isConfigured=$(grep 'OMNISYNC_MODE=""' "${ROOT}/etc/conf.d/${PN}")
+ if [[ -n "${isConfigured}" ]] ; then
+ elog "Be sure to configure ${PN} in ${ROOT}/etc/conf.d before trying to start the service"
+ fi
+}