summaryrefslogtreecommitdiff
path: root/net-misc/olsrd/files/olsrd-0.9.0.2-gtk.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-misc/olsrd/files/olsrd-0.9.0.2-gtk.patch
reinit the tree, so we can have metadata
Diffstat (limited to 'net-misc/olsrd/files/olsrd-0.9.0.2-gtk.patch')
-rw-r--r--net-misc/olsrd/files/olsrd-0.9.0.2-gtk.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-misc/olsrd/files/olsrd-0.9.0.2-gtk.patch b/net-misc/olsrd/files/olsrd-0.9.0.2-gtk.patch
new file mode 100644
index 000000000000..0571340e4d03
--- /dev/null
+++ b/net-misc/olsrd/files/olsrd-0.9.0.2-gtk.patch
@@ -0,0 +1,29 @@
+--- a/gui/linux-gtk/Makefile
++++ b/gui/linux-gtk/Makefile
+@@ -2,14 +2,14 @@
+ include $(TOPDIR)/Makefile.inc
+
+ # hardening flags: -fPIE -Wl,-z,now -pie
+-CFLAGS += $(shell pkg-config --cflags gtk+-2.0) -fPIE -Wno-strict-prototypes \
++CFLAGS += $(shell $(PKG_CONFIG) --cflags glib-2.0 gdk-pixbuf-2.0 gtk+-2.0) -fPIE -Wno-strict-prototypes \
+ -Wno-cast-qual
+-CPPFLAGS += $(shell pkg-config --cflags gtk+-2.0)
++CPPFLAGS += $(shell $(PKG_CONFIG) --cflags glib-2.0 gdk-pixbuf-2.0 gtk+-2.0)
+ LDFLAGS += -pie
+ #LDFLAGS += -Wl,--warn-common
+
+
+-LIBS := $(shell pkg-config --libs gtk+-2.0) -lm
++LIBS := $(shell $(PKG_CONFIG) --libs glib-2.0 gdk-pixbuf-2.0 gtk+-2.0) -lm
+
+ # 32/64 cross compilation
+ ifdef M32
+@@ -30,7 +30,7 @@
+ ifeq ($(VERBOSE),0)
+ @echo "[LD] $@"
+ endif
+- $(MAKECMDPREFIX)$(CC) $(LDFLAGS) -o $@ $(OBJS) $(LIBS)
++ $(MAKECMDPREFIX)$(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(OBJS) $(LIBS)
+
+ .PHONY: clean install
+