summaryrefslogtreecommitdiff
path: root/net-misc/ofono/ofono-2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-30 17:49:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-30 17:49:05 +0000
commit28d8acbb30a9ebda81447e5e3f5210a438ba7d24 (patch)
tree6d6b6b0a1aca19e8118845870c9e6a25bad27963 /net-misc/ofono/ofono-2.0.ebuild
parent840a65e2af3f2cc7527e723a28f6e627a9592fb7 (diff)
gentoo auto-resync : 30:01:2024 - 17:49:05
Diffstat (limited to 'net-misc/ofono/ofono-2.0.ebuild')
-rw-r--r--net-misc/ofono/ofono-2.0.ebuild66
1 files changed, 0 insertions, 66 deletions
diff --git a/net-misc/ofono/ofono-2.0.ebuild b/net-misc/ofono/ofono-2.0.ebuild
deleted file mode 100644
index 892057a6974a..000000000000
--- a/net-misc/ofono/ofono-2.0.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit systemd
-
-DESCRIPTION="Open Source mobile telephony (GSM/UMTS) daemon"
-HOMEPAGE="https://git.kernel.org/pub/scm/network/ofono/ofono.git"
-SRC_URI="https://mirrors.edge.kernel.org/pub/linux/network/${PN}/${P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
-IUSE="+atmodem bluetooth +cdmamodem +datafiles doc dundee examples +isimodem +phonesim +provision +qmimodem tools +udev upower"
-
-REQUIRED_USE="dundee? ( bluetooth )"
-
-RDEPEND=">=sys-apps/dbus-1.6
- >=dev-libs/glib-2.68
- net-misc/mobile-broadband-provider-info
- bluetooth? ( >=net-wireless/bluez-4.99 )
- udev? ( virtual/udev )
- examples? ( dev-python/dbus-python )
- tools? ( virtual/libusb:1 )"
-DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-DOCS=( ChangeLog AUTHORS )
-
-src_configure() {
- econf \
- $(use_enable udev) \
- $(use_enable isimodem) \
- $(use_enable atmodem) \
- $(use_enable cdmamodem) \
- $(use_enable datafiles) \
- $(use_enable dundee) \
- $(use_enable bluetooth) \
- $(use_enable phonesim) \
- $(use_enable provision) \
- $(use_enable qmimodem) \
- $(use_enable tools) \
- $(use_enable examples test) \
- $(use_enable upower) \
- --disable-maintainer-mode \
- --disable-rilmodem
- --localstatedir=/var \
- --with-systemdunitdir="$(systemd_get_systemunitdir)"
-}
-
-src_install() {
- default
-
- if use tools ; then
- dobin tools/auto-enable \
- tools/huawei-audio \
- tools/lookup-provider-name \
- tools/lookup-apn \
- tools/get-location \
- tools/tty-redirector
- fi
-
- newinitd "${FILESDIR}"/${PN}.initd ${PN}
- use doc && dodoc doc/*.txt
-}