summaryrefslogtreecommitdiff
path: root/net-misc/ntpclient/ntpclient-2015.365.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-misc/ntpclient/ntpclient-2015.365.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-misc/ntpclient/ntpclient-2015.365.ebuild')
-rw-r--r--net-misc/ntpclient/ntpclient-2015.365.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-misc/ntpclient/ntpclient-2015.365.ebuild b/net-misc/ntpclient/ntpclient-2015.365.ebuild
new file mode 100644
index 000000000000..6b1b65b208b4
--- /dev/null
+++ b/net-misc/ntpclient/ntpclient-2015.365.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="A NTP (RFC-1305) client for unix-alike computers"
+HOMEPAGE="http://doolittle.icarus.com/ntpclient/"
+SRC_URI="http://doolittle.icarus.com/${PN}/${PN}_${PV/./_}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+src_unpack() {
+ default
+ mv "${WORKDIR}"/${PN}* ${P} || die
+}
+
+src_prepare() {
+ default
+ sed -i -e 's/-O2//;s/LDFLAGS +=/LDLIBS +=/' Makefile || die
+ tc-export CC
+}
+
+src_install() {
+ dobin "${PN}"
+ dodoc README HOWTO rate.awk rate2.awk
+}