summaryrefslogtreecommitdiff
path: root/net-misc/netpipes/netpipes-4.2-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-12 21:55:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-12 21:55:15 +0000
commit7218e1b46bceac05841e90472501742d905fb3fc (patch)
tree56fae051db521b8fce8014cbc8b11484885b14b3 /net-misc/netpipes/netpipes-4.2-r2.ebuild
parent6d691ad5b6239929063441bbd14c489e92e7396e (diff)
gentoo resync : 12.03.2021
Diffstat (limited to 'net-misc/netpipes/netpipes-4.2-r2.ebuild')
-rw-r--r--net-misc/netpipes/netpipes-4.2-r2.ebuild29
1 files changed, 16 insertions, 13 deletions
diff --git a/net-misc/netpipes/netpipes-4.2-r2.ebuild b/net-misc/netpipes/netpipes-4.2-r2.ebuild
index 9fbe3848ce4c..ed14038c1dc8 100644
--- a/net-misc/netpipes/netpipes-4.2-r2.ebuild
+++ b/net-misc/netpipes/netpipes-4.2-r2.ebuild
@@ -1,33 +1,36 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils toolchain-funcs
+EAPI=7
-DESCRIPTION="a package to manipulate BSD TCP/IP stream sockets"
-HOMEPAGE="http://web.purplefrog.com/~thoth/netpipes/"
+inherit toolchain-funcs
+
+DESCRIPTION="Tools to manipulate BSD TCP/IP stream sockets"
+HOMEPAGE="http://web.purplefrog.com/~thoth/netpipes/netpipes.html"
SRC_URI="http://web.purplefrog.com/~thoth/netpipes/ftp/${P}-export.tar.gz"
-LICENSE="GPL-2"
+S="${WORKDIR}/${P}-export"
+LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="amd64 x86"
-S=${WORKDIR}/${P}-export
+PATCHES=(
+ "${FILESDIR}/${P}"-string.patch
+)
src_prepare() {
+ default
sed -i \
- -e 's:CFLAGS =:CFLAGS +=:' \
- -e '/ -o /s:${CFLAGS}:$(CFLAGS) $(LDFLAGS):g' \
+ -e 's;CFLAGS =;CFLAGS +=;' \
+ -e '/ -o /s;${CFLAGS};$(CFLAGS) $(LDFLAGS);g' \
Makefile || die
-
- epatch "${FILESDIR}/${P}"-string.patch
}
src_compile() {
- emake CC=$(tc-getCC)
+ emake CC="$(tc-getCC)"
}
src_install() {
dodir /usr/share/man
- emake INSTROOT="${D}"/usr INSTMAN="${D}"/usr/share/man install
+ emake INSTROOT="${ED}"/usr INSTMAN="${ED}"/usr/share/man install
}