summaryrefslogtreecommitdiff
path: root/net-misc/netpipes/netpipes-4.2-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-misc/netpipes/netpipes-4.2-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-misc/netpipes/netpipes-4.2-r2.ebuild')
-rw-r--r--net-misc/netpipes/netpipes-4.2-r2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-misc/netpipes/netpipes-4.2-r2.ebuild b/net-misc/netpipes/netpipes-4.2-r2.ebuild
new file mode 100644
index 000000000000..36be1f20476a
--- /dev/null
+++ b/net-misc/netpipes/netpipes-4.2-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="a package to manipulate BSD TCP/IP stream sockets"
+HOMEPAGE="http://web.purplefrog.com/~thoth/netpipes/"
+SRC_URI="http://web.purplefrog.com/~thoth/netpipes/ftp/${P}-export.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+S=${WORKDIR}/${P}-export
+
+src_prepare() {
+ sed -i \
+ -e 's:CFLAGS =:CFLAGS +=:' \
+ -e '/ -o /s:${CFLAGS}:$(CFLAGS) $(LDFLAGS):g' \
+ Makefile || die
+
+ epatch "${FILESDIR}/${P}"-string.patch
+}
+
+src_compile () {
+ emake CC=$(tc-getCC)
+}
+
+src_install() {
+ dodir /usr/share/man
+ emake INSTROOT="${D}"/usr INSTMAN="${D}"/usr/share/man install
+}