summaryrefslogtreecommitdiff
path: root/net-misc/netpipe/netpipe-1.0.0_beta2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-misc/netpipe/netpipe-1.0.0_beta2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-misc/netpipe/netpipe-1.0.0_beta2.ebuild')
-rw-r--r--net-misc/netpipe/netpipe-1.0.0_beta2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-misc/netpipe/netpipe-1.0.0_beta2.ebuild b/net-misc/netpipe/netpipe-1.0.0_beta2.ebuild
new file mode 100644
index 000000000000..51599bd00c5f
--- /dev/null
+++ b/net-misc/netpipe/netpipe-1.0.0_beta2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit toolchain-funcs
+
+DESCRIPTION="tool to reliably distribute binary data using UDP broadcasting techniques"
+HOMEPAGE="http://www.wudika.de/~jan/netpipe/"
+SRC_URI="http://www.wudika.de/~jan/netpipe/${PN}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="ppc x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e "s:^OPT=.*:OPT = ${CFLAGS}:" \
+ -e "s:^CC=.*:CC = $(tc-getCC):" \
+ Makefile
+}
+
+src_install() {
+ dobin netpipe || die "dobin failed"
+ dodoc DOCUMENTATION INSTALL TECH-NOTES
+}