summaryrefslogtreecommitdiff
path: root/net-misc/netkit-telnetd/netkit-telnetd-0.17-r13.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /net-misc/netkit-telnetd/netkit-telnetd-0.17-r13.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'net-misc/netkit-telnetd/netkit-telnetd-0.17-r13.ebuild')
-rw-r--r--net-misc/netkit-telnetd/netkit-telnetd-0.17-r13.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/net-misc/netkit-telnetd/netkit-telnetd-0.17-r13.ebuild b/net-misc/netkit-telnetd/netkit-telnetd-0.17-r13.ebuild
new file mode 100644
index 000000000000..7423dd55a7dc
--- /dev/null
+++ b/net-misc/netkit-telnetd/netkit-telnetd-0.17-r13.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+inherit cmake
+
+PATCHLEVEL=42
+DESCRIPTION="Standard Linux telnet client and server"
+#old HOMEPAGE="ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/"
+# This might be the best HOMEPAGE now?
+HOMEPAGE="https://launchpad.net/netkit-telnet"
+# http://packages.debian.org/stablesource/netkit-telnet
+# http://packages.debian.org/testing/source/netkit-telnet
+# No upstream mirror exists anymore?
+# old ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/netkit-telnet-${PV}.tar.gz
+SRC_URI="mirror://gentoo/netkit-telnet-${PV}.tar.gz
+ mirror://debian/pool/main/n/netkit-telnet/netkit-telnet_0.17-${PATCHLEVEL}.debian.tar.xz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=sys-libs/ncurses-5.2:=
+ !net-misc/telnet-bsd"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/netkit-telnet-${PV}
+
+src_prepare() {
+ # Patch: [0]
+ # Gentoo used to lack a maintainer for this package.
+ # A security problem arose. While reviewing our options for how
+ # should we proceed with the security bug we decided it would be
+ # better to just stay in sync with debian's own netkit-telnet
+ # package. Lots of bug fixes by them over time which were not in
+ # our telnetd.
+ rm "${WORKDIR}/debian/patches/use-cmake-as-buildsystem-debian-extras.patch" || die
+ eapply "${WORKDIR}/debian/patches"
+ eapply "${FILESDIR}/netkit-telnetd-0.17-r13-gentooification.patch"
+
+ cmake_src_prepare
+}
+
+src_install() {
+ cmake_src_install
+
+ dosym telnetd /usr/sbin/in.telnetd
+ dodoc "${FILESDIR}/net.issue.sample"
+ newdoc telnet/README README.telnet
+ newdoc telnet/TODO TODO.telnet
+ insinto /etc/xinetd.d
+ newins "${FILESDIR}/telnetd.xinetd" telnetd
+}